RhinoCommon API
InstanceDefinitionGeometry Class |
Represents a block definition in a File3dm. This is the same as
Rhino.DocObjects.InstanceDefinition, but not associated with a RhinoDoc.

SystemObject
Rhino.RuntimeCommonObject
Rhino.GeometryGeometryBase
Rhino.GeometryInstanceDefinitionGeometry
Rhino.RuntimeCommonObject
Rhino.GeometryGeometryBase
Rhino.GeometryInstanceDefinitionGeometry
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)

The InstanceDefinitionGeometry type exposes the following members.

Name | Description | |
---|---|---|
![]() | InstanceDefinitionGeometry |
Initializes a new block definition.
|

Name | Description | |
---|---|---|
![]() | ComponentStatus |
Gets or sets the component status of the model component.
(Inherited from ModelComponent.) |
![]() | ComponentType |
Returns InstanceDefinition.
(Overrides ModelComponentComponentType.) |
![]() | DeletedName |
Gets the name of a component that is deleted.
(Inherited from ModelComponent.) |
![]() | Description |
Gets or sets the description of the definition.
|
![]() | Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) |
![]() | HasBrepForm |
Returns true if the Brep.TryConvertBrep function will be successful for this object
(Inherited from GeometryBase.) |
![]() | HasId |
Returns a value indicating whether the component has an ID.
(Inherited from ModelComponent.) |
![]() | HasIndex |
Returns a value indicating whether the component has an Index.
(Inherited from ModelComponent.) |
![]() | HasName |
Returns a value indicating whether the component has a Name.
(Inherited from ModelComponent.) |
![]() | HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) |
![]() | Id |
unique id for this instance definition
In Rhino for Windows 6.8, this member is inherited from ModelComponentId. |
![]() | IdIsLocked |
Returns a value indicating whether the component ID is already locked.
(Inherited from ModelComponent.) |
![]() | Index |
Gets or sets the model component index attribute.
(Inherited from ModelComponent.) |
![]() | IndexIsLocked |
Returns a value indicating whether the component Index is already locked.
(Inherited from ModelComponent.) |
![]() | IsComponentStatusLocked |
The component status itself can be locked. This returns an indication.
(Inherited from ModelComponent.) |
![]() | IsDeformable |
true if object can be accurately modified with "squishy" transformations like
projections, shears, and non-uniform scaling.
(Inherited from GeometryBase.) |
![]() | IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from GeometryBase.)In Rhino for Windows 6.8, this member is inherited from CommonObjectIsDocumentControlled. |
![]() | IsSystemComponent |
True if this model component is a system constant.
(Inherited from ModelComponent.)An incomplete list of system constant model components is below:
|
![]() | IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) |
![]() ![]() | Name |
Gets or sets the name of the definition.
In Rhino for Windows 6.8, this member is inherited from ModelComponentName. |
![]() | NameIsLocked |
Returns a value indicating whether the component Name is already locked.
(Inherited from ModelComponent.) |
![]() | ObjectType |
Useful for switch statements that need to differentiate between
basic object types like points, curves, surfaces, and so on.
(Inherited from GeometryBase.) |
![]() | UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) |
![]() | UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use sharable set of information.
(Inherited from CommonObject.) |
![]() | UserStringCount |
Gets the amount of user strings.
(Inherited from GeometryBase.) |

Name | Description | |
---|---|---|
![]() | ClearId |
Resets the HasId property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearIndex |
Resets the HasIndex property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ClearName |
Resets the HasName property of the model component to false, if possible.
(Inherited from ModelComponent.) |
![]() | ComponentIndex |
If this piece of geometry is a component in something larger, like a BrepEdge
in a Brep, then this function returns the component index.
(Inherited from GeometryBase.) |
![]() | ConstructConstObject |
Assigns a parent object and a subobject index to this.
(Inherited from CommonObject.) |
![]() | DataCRC |
Increments the Cyclic Redundancy Check value by this instance.
(Inherited from ModelComponent.) |
![]() | Dispose |
Actively reclaims unmanaged resources that this instance uses.
(Inherited from CommonObject.) |
![]() | Dispose(Boolean) |
For derived class implementers.
(Inherited from CommonObject.)This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method. |
![]() | Duplicate |
Constructs a deep (full) copy of this object.
(Inherited from GeometryBase.) |
![]() | DuplicateShallow |
Constructs a light copy of this object. By "light", it is meant that the same
underlying data is used until something is done to attempt to change it. For example,
you could have a shallow copy of a very heavy mesh object and the same underlying
data will be used when doing things like inspecting the number of faces on the mesh.
If you modify the location of one of the mesh vertices, the shallow copy will create
a full duplicate of the underlying mesh data and the shallow copy will become a
deep copy.
(Inherited from GeometryBase.) |
![]() | EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
call this function as many times as you want.
(Inherited from CommonObject.) |
![]() | Equals | (Inherited from Object.) |
![]() | Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Inherited from CommonObject.) |
![]() ![]() | GetBoundingBox(Boolean) |
Boundingbox solver. Gets the world axis aligned boundingbox for the geometry.
(Inherited from GeometryBase.) |
![]() ![]() | GetBoundingBox(Plane) |
Aligned Boundingbox solver. Gets the plane aligned boundingbox.
(Inherited from GeometryBase.) |
![]() | GetBoundingBox(Transform) |
Aligned Boundingbox solver. Gets the world axis aligned boundingbox for the transformed geometry.
(Inherited from GeometryBase.) |
![]() | GetBoundingBox(Plane, Box) |
Aligned Boundingbox solver. Gets the plane aligned boundingbox.
(Inherited from GeometryBase.) |
![]() | GetHashCode | (Inherited from Object.) |
![]() | GetObjectData |
Populates a System.Runtime.Serialization.SerializationInfo with the data needed to serialize the target object.
(Inherited from CommonObject.) |
![]() | GetObjectIds |
list of object ids in the instance geometry table
|
![]() | GetType | (Inherited from Object.) |
![]() | GetUserString |
Gets user string from this geometry.
(Inherited from GeometryBase.) |
![]() | GetUserStrings |
Gets a copy of all (user key string, user value string) pairs attached to this geometry.
(Inherited from GeometryBase.) |
![]() | IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
object happens not to be valid.
(Inherited from CommonObject.) |
![]() | LockId |
Locks the component Id property.
(Inherited from ModelComponent.) |
![]() | LockIndex |
Locks the component Index property.
(Inherited from ModelComponent.) |
![]() | LockName |
Locks the component Name property.
(Inherited from ModelComponent.) |
![]() | MakeDeformable |
If possible, converts the object into a form that can be accurately modified
with "squishy" transformations like projections, shears, an non-uniform scaling.
(Inherited from GeometryBase.) |
![]() | MemberwiseClone | (Inherited from Object.) |
![]() | MemoryEstimate |
Computes an estimate of the number of bytes that this object is using in memory.
(Inherited from GeometryBase.) |
![]() | NonConstOperation |
For derived classes implementers.
(Inherited from CommonObject.)Defines the necessary implementation to free the instance from being const. |
![]() | OnSwitchToNonConst |
Is called when a non-const operation occurs.
(Inherited from GeometryBase.)In Rhino for Windows 6.8, this member is inherited from CommonObjectOnSwitchToNonConst. |
![]() | Rotate |
Rotates the object about the specified axis. A positive rotation
angle results in a counter-clockwise rotation about the axis (right hand rule).
(Inherited from GeometryBase.) |
![]() | Scale |
Scales the object by the specified factor. The scale is centered at the origin.
(Inherited from GeometryBase.) |
![]() | SetUserString |
Attach a user string (key,value combination) to this geometry.
(Inherited from GeometryBase.) |
![]() | ToString | (Inherited from Object.) |
![]() | ToString |
Returns the name of the model component type, and then its name and index.
(Inherited from ModelComponent.) |
![]() | Transform |
Transforms the geometry. If the input Transform has a SimilarityType of
OrientationReversing, you may want to consider flipping the transformed
geometry after calling this function when it makes sense. For example,
you may want to call Flip() on a Brep after transforming it.
(Inherited from GeometryBase.) |
![]() | Translate(Vector3d) | Translates the object along the specified vector. (Inherited from GeometryBase.) |
![]() | Translate(Double, Double, Double) | Translates the object along the specified vector. (Inherited from GeometryBase.) |

Rhino for Mac
Supported in: 5.4Rhino for Windows
Supported in: 6.8