MeshNgon Class

MeshNgon Class

Represents a mesh ngon.

When retrieved from the Ngon property of a mesh, this contains faces that have edge valence strictly higher than 4.

When retrieving Ngons from GetNgonAndFacesEnumerable, this might contain also triangles and quads.

Inheritance Hierarchy
SystemObject
  Rhino.GeometryMeshNgon

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshNgon : IEquatable<MeshNgon>, 
	IComparable<MeshNgon>, IComparable
Public Class MeshNgon
	Implements IEquatable(Of MeshNgon), IComparable(Of MeshNgon), 
	IComparable

The MeshNgon type exposes the following members.

Properties
  NameDescription
Public propertyBoundaryVertexCount
Get the number of vertices in this ngon. about length information.
Public propertyStatic memberEmpty
Gets an empty MeshNgon.
Public propertyFaceCount
Get the number of faces in this ngon.
Public propertyItem
Get a mesh vertex index from the ngon's vertex index list.
Top
Methods
  NameDescription
Public methodBoundaryVertexIndexList
Get the outer boundary mesh vertex list of the ngon.

Vertices are sorted counterclockwise with respect to the direction of the face, although the degree by which vertex normals will respect this might vary.

Public methodCompareTo
Compares this MeshNgon with otherNgon and returns a value of 1, 0, or -1.

Priority is for vertex count, then face count, then vertex index list values, then face index list values.

Public methodStatic memberCreate
Constructs an ngon from lists of mesh vertex and face indexes.
Public methodEquals(Object)
Determines if otherObj is a MeshNgon and is identical to this ngon.
(Overrides ObjectEquals(Object).)
Public methodEquals(MeshNgon)
Determines if this ngon and otherNgon are identical.
Public methodFaceIndexList
Get the ngon's mesh face index list.
Public methodGetHashCode
Returns a runtime-stable hashcode for the current mesh ngon. You are not allowed to rely on persistance of this hashcode in serialization, but for each instance of the application, this hashcode will be the same for ngons with identical vertex and face lists.
(Overrides ObjectGetHashCode.)
Public methodSet
Set the ngon vertex and face index lists.
Public methodToString
Returns a string representation for this MeshNgon. This is to provide a meaningful visualization of this structure and is subject to change in newer releases.
(Overrides ObjectToString.)
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Determines whether two MeshNgon structures have equal values.
Public operatorStatic memberInequality
Determines whether two MeshNgon structures have different values.
Top
Version Information

Rhino for Windows

Supported in: 6.8
See Also