Plane Structure

Plane Structure

Represents the value of a center point and two axes in a plane in three dimensions.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct Plane : IEquatable<Plane>, 
	IEpsilonComparable<Plane>
<SerializableAttribute>
Public Structure Plane
	Implements IEquatable(Of Plane), IEpsilonComparable(Of Plane)

The Plane type exposes the following members.

Constructors
  NameDescription
Public methodPlane(Plane)
Copy constructor.

This is nothing special and performs the same as assigning to another variable.

Public methodCode examplePlane(Point3d, Vector3d)
Constructs a plane from a point and a normal vector.
Public methodCode examplePlane(Point3d, Point3d, Point3d)
Initializes a plane from three non-colinear points.
Public methodPlane(Point3d, Vector3d, Vector3d)
Constructs a plane from a point and two vectors in the plane.
Public methodPlane(Double, Double, Double, Double)
Constructs a plane from an equation ax+by+cz=d.
Top
Properties
  NameDescription
Public propertyIsValid
Gets a value indicating whether or not this is a valid plane. A plane is considered to be valid when all fields contain reasonable information and the equation jibes with point and zaxis.
Public propertyNormal
Gets the normal of this plane. This is essentially the ZAxis of the plane.
Public propertyOrigin
Gets or sets the origin point of this plane.
Public propertyOriginX
Gets or sets the X coordinate of the origin of this plane.
Public propertyOriginY
Gets or sets the Y coordinate of the origin of this plane.
Public propertyOriginZ
Gets or sets the Z coordinate of the origin of this plane.
Public propertyStatic memberUnset
Gets a plane that contains Unset origin and axis vectors.
Public propertyStatic memberWorldXY
plane coincident with the World XY plane.
Public propertyStatic memberWorldYZ
plane coincident with the World YZ plane.
Public propertyStatic memberWorldZX
plane coincident with the World ZX plane.
Public propertyXAxis
Gets or sets the X axis vector of this plane.
Public propertyYAxis
Gets or sets the Y axis vector of this plane.
Public propertyZAxis
Gets or sets the Z axis vector of this plane.
Top
Methods
  NameDescription
Public methodClone
Returns a deep of this instance.
Public methodCode exampleClosestParameter
Gets the parameters of the point on the plane closest to a test point.
Public methodClosestPoint
Gets the point on the plane closest to a test point.
Public methodCode exampleDistanceTo(Point3d)
Returns the signed distance from testPoint to its projection onto this plane. If the point is below the plane, a negative distance is returned.
Public methodDistanceTo(BoundingBox, Double, Double)
Returns the signed minimum and maximum distances from bbox to this plane.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines if an object is a plane and has the same components as this plane.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Plane)
Determines if another plane has the same components as this plane.
Public methodExtendThroughBox(BoundingBox, Interval, Interval)
Extends this plane through a bounding box.
Public methodExtendThroughBox(Box, Interval, Interval)
Extend this plane through a Box.
Public methodStatic memberFitPlaneToPoints(IEnumerablePoint3d, Plane)
Fit a plane through a collection of points.
Public methodStatic memberFitPlaneToPoints(IEnumerablePoint3d, Plane, Double)
Fit a plane through a collection of points.
Public methodFlip
Flip this plane by swapping out the X and Y axes and inverting the Z axis.
Public methodGetHashCode
Gets a non-unique hashing code for this entity.
(Overrides ValueTypeGetHashCode.)
Public methodGetPlaneEquation
Gets the plane equation for this plane in the format of Ax+By+Cz+D=0.
Public methodPointAt(Double, Double)
Evaluate a point on the plane.
Public methodPointAt(Double, Double, Double)
Evaluate a point on the plane.
Public methodRemapToPlaneSpace
Convert a point from World space coordinates into Plane space coordinates.
Public methodRotate(Double, Vector3d)
Rotate the plane about its origin point.
Public methodRotate(Double, Vector3d, Point3d)
Rotate the plane about a custom anchor point.
Public methodRotate(Double, Double, Vector3d)
Rotate the plane about its origin point.
Public methodRotate(Double, Double, Vector3d, Point3d)
Rotate the plane about a custom anchor point.
Public methodToString
Constructs the string representation of this plane.
(Overrides ValueTypeToString.)
Public methodTransform
Transform the plane with a Transformation matrix.
Public methodTranslate
Translate (move) the plane along a vector.
Public methodUpdateEquation
Update Equations
Public methodValueAt
Get the value of the plane equation at the point.
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Determines if two planes are equal.
Public operatorStatic memberInequality
Determines if two planes are different.
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also