Dialogs Class

Dialogs Class

[Missing <summary> documentation for "T:Rhino.UI.Dialogs"]

Inheritance Hierarchy
SystemObject
  Rhino.UIDialogs

Namespace:  Rhino.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public static class Dialogs
Public NotInheritable Class Dialogs

The Dialogs type exposes the following members.

Methods
  NameDescription
Public methodStatic memberKillSplash
Destroy the splash screen if it is being displayed.
Public methodStatic memberCode exampleSetCustomColorDialog
Public methodStatic memberShowAboutDialog
Public methodStatic memberShowCheckListBox
Displays Rhino's check list box.
Public methodStatic memberCode exampleShowColorDialog(Color)
Display Rhino's color selection dialog.
Public methodStatic memberShowColorDialog(Color4f, Boolean)
Displays the standard modal color picker dialog for floating point colors.
Public methodStatic memberShowColorDialog(Color, Boolean, String)
Display Rhino's color selection dialog.
Public methodStatic memberShowColorDialog(Object, Color4f, Boolean)
Displays the standard modal color picker dialog for floating point colors.
Public methodStatic memberShowColorDialog(IWin32Window, Color4f, Boolean) Obsolete.
Displays the standard modal color picker dialog for floating point colors.
Public methodStatic memberShowColorDialog(Object, Color4f, Boolean, DialogsOnColorChangedEvent)
Displays the standard modal color picker dialog for floating point colors.
Public methodStatic memberShowComboListBox
Displays Rhino's combo list box.
Public methodStatic memberShowContextMenu
Creates an ETO ContextMenu from an array of strings. Use the modes array to enable/disable menu items
Public methodStatic memberShowEditBox
Display dialog prompting the user to enter a string.
Public methodStatic memberShowLineTypes
Displayes Rhino's Linetype list and returns the ID of the selected line type as a string.
Public methodStatic memberShowListBox(String, String, IList)
Public methodStatic memberShowListBox(String, String, IList, Object)
Public methodStatic memberShowMessage(String, String)
Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.
Public methodStatic memberShowMessage(String, String, ShowMessageButton, ShowMessageIcon)
Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.
Public methodStatic memberShowMessage(Object, String, String, ShowMessageButton, ShowMessageIcon, ShowMessageDefaultButton, ShowMessageOptions, ShowMessageMode)
Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.
Public methodStatic memberShowMessageBox(String, String) Obsolete.
Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.
Public methodStatic memberShowMessageBox(String, String, MessageBoxButtons, MessageBoxIcon) Obsolete.
Same as System.Windows.Forms.MessageBox.Show but using a message box tailored to Rhino.
Public methodStatic memberShowMultiListBox
Public methodStatic memberShowNumberBox(String, String, Double)
Public methodStatic memberShowNumberBox(String, String, Double, Double, Double)
Public methodStatic memberShowPropertyListBox
Public methodStatic memberShowSelectLayerDialog
Displays Rhino's single layer selection dialog.
Public methodStatic memberShowSelectLinetypeDialog
Displays Rhino's single linetype selection dialog.
Public methodStatic memberShowSelectMultipleLayersDialog
Public methodStatic memberShowSemiModal Obsolete.
Show a windows form that is modal in the sense that this function does not return until the form is closed, but also allows for interaction with other elements of the Rhino user interface.
Public methodStatic memberShowSunDialog
Show the tabbed sun dialog.
Public methodStatic memberShowTextDialog
Display a text dialog similar to the dialog used for the "What" command.
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also