ObjectTable.Replace Method (Guid, Mesh)

ObjectTableReplace Method (Guid, Mesh)

Replaces one object with new mesh object.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Replace(
	Guid objectId,
	Mesh mesh
)
Public Function Replace ( 
	objectId As Guid,
	mesh As Mesh
) As Boolean

Parameters

objectId
Type: SystemGuid
Id of object to be replaced.
mesh
Type: Rhino.GeometryMesh
new mesh to be added A duplicate of the mesh is added to the Rhino model.

Return Value

Type: Boolean
true if successful.
See Also