Mesh Class

Mesh Class

Represents a geometry type that is defined by vertices and faces.

This is often called a face-vertex mesh.

Inheritance Hierarchy
SystemObject
  Rhino.RuntimeCommonObject
    Rhino.GeometryGeometryBase
      Rhino.GeometryMesh

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class Mesh : GeometryBase
<SerializableAttribute>
Public Class Mesh
	Inherits GeometryBase

The Mesh type exposes the following members.

Constructors
  NameDescription
Public methodCode exampleMesh
Initializes a new empty mesh.
Protected methodMesh(SerializationInfo, StreamingContext)
Protected constructor for internal use.
Top
Properties
  NameDescription
Public propertyComponentStates
Gets access to the vertex hidden/visibility collection in this mesh. This is a runtime property and it is not saved in the 3dm file.
Public propertyDisjointMeshCount
Gets the number of disjoint (topologically unconnected) pieces in this mesh.
Public propertyFaceNormals
Gets access to the face normal collection in this mesh.
Public propertyCode exampleFaces
Gets access to the mesh face list.
Public propertyHasCachedTextureCoordinates
Will return true if SetCachedTextureCoordinates has been called; otherwise will return false.
Public propertyHasPrincipalCurvatures
HasPrincipalCurvatures
Public propertyIsClosed
Gets a value indicating whether a mesh is considered to be closed (solid). A mesh is considered solid when every mesh edge borders two or more faces.
Public propertyNgons
Gets access to the mesh ngon list.

Ngons represent groups of Faces (triangles + quads).

Faces are used to tessellate an Ngon internally.

When a triangle or quad is referenced in the Ngon list, it is no longer visualized and conceived as a single entity, but takes part of the Ngon.

If you need to get access to both Ngons and the faces that are not referenced by Ngons, that is, all polygons that are visible in the mesh, then use the GetNgonAndFacesEnumerable helper method.

Public propertyCode exampleNormals
Gets access to the vertex normal collection in this mesh.
Public propertyPartitionCount
Number of partition information chunks stored on this mesh based on the last call to CreatePartitions
Public propertyTextureCoordinates
Gets access to the vertex texture coordinate collection in this mesh.
Public propertyTopologyEdges
Gets the MeshTopologyEdgeList object associated with this mesh.

This object stores edge connectivity.

Public propertyTopologyVertices
Gets the MeshTopologyVertexList object associated with this mesh.

This object stores vertex connectivity and the indices of vertices that were unified while computing the edge topology.

Public propertyVertexColors
Gets access to the (optional) vertex color collection in this mesh.
Public propertyCode exampleVertices
Gets access to the vertices set of this mesh.
Top
Methods
  NameDescription
Public methodCode exampleAppend(Mesh)
Appends a copy of another mesh to this one and updates indices of appended mesh parts.
Public methodAppend(IEnumerableMesh)
Append a list of meshes. This function is much more efficient than making repeated calls to Mesh.Append(Mesh) when lots of meshes are being joined into a single large mesh.
Public methodCheck
Examines the mesh and logs a description of what it finds right or wrong. The various properties the function checks for are described in MeshCheckParameters.
Public methodClearSurfaceData
Removes surface parameters, curvature parameters and surface statistics from the mesh.
Public methodClearTextureData
Removes all texture coordinate information from this mesh.
Public methodClosestMeshPoint
Gets the point on the mesh that is closest to a given test point. Similar to the ClosestPoint function except this returns a MeshPoint class which includes extra information beyond just the location of the closest point.
Public methodClosestPoint(Point3d)
Gets the point on the mesh that is closest to a given test point.
Public methodClosestPoint(Point3d, Point3d, Double)
Gets the point on the mesh that is closest to a given test point.
Public methodClosestPoint(Point3d, Point3d, Vector3d, Double)
Gets the point on the mesh that is closest to a given test point.
Public methodCollapseFacesByArea
Collapses multiple mesh faces, with areas less than LessThanArea and greater than GreaterThanArea, based on the principles found in Stan Melax's mesh reduction PDF, see http://pomax.nihongoresources.com/downloads/PolygonReduction.pdf
Public methodCollapseFacesByByAspectRatio
Collapses a multiple mesh faces, determined by face aspect ratio, based on criteria found in Stan Melax's polygon reduction, see http://pomax.nihongoresources.com/downloads/PolygonReduction.pdf
Public methodCollapseFacesByEdgeLength
Collapses multiple mesh faces, with greater/less than edge length, based on the principles found in Stan Melax's mesh reduction PDF, see http://pomax.nihongoresources.com/downloads/PolygonReduction.pdf
Public methodColorAt(MeshPoint)
Evaluate a mesh color at a set of barycentric coordinates.
Public methodColorAt(Int32, Double, Double, Double, Double)
Evaluate a mesh normal at a set of barycentric coordinates. Barycentric coordinates must be assigned in accordance with the rules as defined by MeshPoint.T.
Public methodCode exampleCompact
Removes any unreferenced objects from arrays, re-indexes as needed and shrinks arrays to minimum required size.
Public methodStatic memberComputeThickness(IEnumerableMesh, Double)
Compute thickness metrics for this mesh.
Public methodStatic memberComputeThickness(IEnumerableMesh, Double, CancellationToken)
Compute thickness metrics for this mesh.
Public methodStatic memberComputeThickness(IEnumerableMesh, Double, Double, CancellationToken)
Compute thickness metrics for this mesh.
Public methodCopyFrom
Copies mesh values into this mesh from another mesh.
Public methodStatic memberCreateBooleanDifference
Computes the solid difference of two sets of Meshes.
Public methodStatic memberCreateBooleanIntersection
Computes the solid intersection of two sets of meshes.
Public methodStatic memberCreateBooleanSplit
Splits a set of meshes with another set.
Public methodStatic memberCreateBooleanUnion
Computes the solid union of a set of meshes.
Public methodStatic memberCreateContourCurves(Mesh, Plane)
Constructs contour curves for a mesh, sectioned at a plane.
Public methodStatic memberCode exampleCreateContourCurves(Mesh, Point3d, Point3d, Double)
Constructs contour curves for a mesh, sectioned along a linear axis.
Public methodStatic memberCreateFromBox(BoundingBox, Int32, Int32, Int32)
Constructs new mesh that matches a bounding box.
Public methodStatic memberCreateFromBox(Box, Int32, Int32, Int32)
Constructs new mesh that matches an aligned box.
Public methodStatic memberCreateFromBox(IEnumerablePoint3d, Int32, Int32, Int32)
Constructs new mesh from 8 corner points.
Public methodStatic memberCode exampleCreateFromBrep(Brep) Obsolete.
Constructs a mesh from a brep.
Public methodStatic memberCode exampleCreateFromBrep(Brep, MeshingParameters)
Constructs a mesh from a brep.
Public methodStatic memberCreateFromClosedPolyline
Attempts to create a Mesh that is a triangulation of a simple closed polyline that projects onto a plane.
Public methodStatic memberCreateFromCone(Cone, Int32, Int32)
Constructs a solid mesh cone.
Public methodStatic memberCreateFromCone(Cone, Int32, Int32, Boolean)
Constructs a mesh cone.
Public methodStatic memberCreateFromCone(Cone, Int32, Int32, Boolean, Boolean)
Constructs a mesh cone.
Public methodStatic memberCreateFromCurveExtrusion
Constructs a new extrusion from a curve.
Public methodStatic memberCreateFromCurvePipe
Constructs a new mesh pipe from a curve.
Public methodStatic memberCreateFromCylinder(Cylinder, Int32, Int32)
Constructs a capped mesh cylinder.
Public methodStatic memberCreateFromCylinder(Cylinder, Int32, Int32, Boolean, Boolean)
Constructs a mesh cylinder.
Public methodStatic memberCreateFromCylinder(Cylinder, Int32, Int32, Boolean, Boolean, Boolean)
Constructs a mesh cylinder.
Public methodStatic memberCreateFromFilteredFaceList
Constructs a sub-mesh, that contains a filtered list of faces.
Public methodStatic memberCreateFromIterativeCleanup
Repairs meshes with vertices that are too near, using a tolerance value.
Public methodStatic memberCreateFromLines
Creates a mesh by analizing the edge structure. Input lines could be from the extraction of edges from an original mesh.
Public methodStatic memberCreateFromPlanarBoundary(Curve, MeshingParameters) Obsolete.
Do not use this overload. Use version that takes a tolerance parameter instead.
Public methodStatic memberCreateFromPlanarBoundary(Curve, MeshingParameters, Double)
Attempts to construct a mesh from a closed planar curve.RhinoMakePlanarMeshes
Public methodStatic memberCreateFromPlane
Constructs a planar mesh grid.
Public methodStatic memberCreateFromSphere
Constructs a mesh sphere.
Public methodStatic memberCreateFromSubD
Create a mesh from a SubD limit surface
Public methodStatic memberCreateFromSubDControlNet
Create a mesh from a SubD control net
Public methodStatic memberCreateFromSurface(Surface)
Constructs a mesh from a surface
Public methodStatic memberCreateFromSurface(Surface, MeshingParameters)
Constructs a mesh from a surface
Public methodStatic memberCreateFromTessellation
Attempts to create a mesh that is a triangulation of a list of points, projected on a plane, including its holes and fixed edges.
Public methodStatic memberCreateFromTorus
Constructs a mesh torus.
Public methodStatic memberCreateIcoSphere
Constructs a icospherical mesh. A mesh icosphere differs from a standard UV mesh sphere in that it's vertices are evenly distributed. A mesh icosphere starts from an icosahedron (a regular polyhedron with 20 equilateral triangles). It is then refined by splitting each triangle into 4 smaller triangles. This splitting can be done several times.
Public methodCreatePartitions
In ancient times (or modern smart phone times), some rendering engines were only able to process small batches of triangles and the CreatePartitions() function was provided to partition the mesh into subsets of vertices and faces that those rendering engines could handle.
Public methodStatic memberCreatePatch
Construct a mesh patch from a variety of input geometry.
Public methodStatic memberCreateQuadSphere
Constructs a quad mesh sphere. A quad mesh sphere differs from a standard UV mesh sphere in that it's vertices are evenly distributed. A quad mesh sphere starts from a cube (a regular polyhedron with 6 square sides). It is then refined by splitting each quad into 4 smaller quads. This splitting can be done several times.
Public methodDestroyPartition
Destroys mesh partition.
Public methodDestroyTopology
Removes topology data, forcing all topology information to be recomputed.
Public methodDestroyTree
Destroys the mesh vertex access tree.
Public methodDuplicate
Constructs a copy of this mesh. This is the same as DuplicateMesh.
(Overrides GeometryBaseDuplicate.)
Public methodDuplicateMesh
Constructs a copy of this mesh. This is the same as Duplicate.
Public methodEvaluateMeshGeometry
If the mesh has SurfaceParameters, the surface is evaluated at these parameters and the mesh geometry is updated.
Public methodExplodeAtUnweldedEdges
Explode the mesh into sub-meshes where a sub-mesh is a collection of faces that are contained within a closed loop of "unwelded" edges. Unwelded edges are edges where the faces that share the edge have unique mesh vertexes (not mesh topology vertexes) at both ends of the edge.
Public methodExtendSelectionByEdgeRidge
Suggests an extension of a selection set by using information related with topology and alignment.
Public methodExtendSelectionByFaceLoop
Suggests an extension of a face selection set by using information related with topology and alignment.
Public methodExtractNonManifoldEdges
Extracts, or removes, non-manifold mesh edges.
Public methodFileHole
Given a starting "naked" edge index, this function attempts to determine a "hole" by chaining additional naked edges together until if returns to the start index. Then it triangulates the closed polygon and either adds the faces to the mesh.
Public methodFillHoles
Attempts to determine "holes" in the mesh by chaining naked edges together. Then it triangulates the closed polygons adds the faces to the mesh.
Public methodFlip(Boolean, Boolean, Boolean)
Reverses the direction of the mesh.
Public methodFlip(Boolean, Boolean, Boolean, Boolean)
Reverses the direction of the mesh.
Public methodGetCachedTextureCoordinates
Call this method to get cached texture coordinates for a texture mapping with the specified Id.
Public methodGetNakedEdgePointStatus
Returns an array of Boolean values equal in length to the number of vertices in this mesh. Each value corresponds to a mesh vertex and is set to true if the vertex is not completely surrounded by faces.
Public methodCode exampleGetNakedEdges
Returns all edges of a mesh that are considered "naked" in the sense that the edge only has one face.
Public methodGetNgonAndFacesCount
Retrieves the count of items that GetNgonAndFacesEnumerable will provide.
Public methodGetNgonAndFacesEnumerable
Retrieves a complete enumerable, i.e., one that provides an iterator over every face that is present, no matter if defined as a triangle, a quad, or a strictly over-four-sided ngon.
Public methodGetOutlines(Plane)
Constructs the outlines of a mesh projected against a plane.
Public methodGetOutlines(RhinoViewport)
Constructs the outlines of a mesh. The projection information in the viewport is used to determine how the outlines are projected.
Public methodGetOutlines(ViewportInfo, Plane)
Constructs the outlines of a mesh.
Public methodGetPartition
Retrieves a partition. See CreatePartitions(Int32, Int32) for details.
Public methodGetSelfIntersections
Gets the intersections of this mesh with itself.
Public methodGetUnsafeLock
Allows to obtain unsafe pointers to the underlying unmanaged data structures of the mesh.
Public methodHealNakedEdges
Attempts to "heal" naked edges in a mesh based on a given distance. First attempts to move vertexes to neighboring vertexes that are within that distance away. Then it finds edges that have a closest point to the vertex within the distance and splits the edge. When it finds one it splits the edge and makes two new edges using that point.
Public methodIsManifold
Gets a value indicating whether or not the mesh is manifold. A manifold mesh does not have any edge that borders more than two faces.
Public methodIsPointInside
Determines if a point is inside a solid mesh.
Protected methodNonConstOperation
Clear local cache on non constant calls
(Overrides GeometryBaseNonConstOperation.)
Public methodNormalAt(MeshPoint)
Evaluate a mesh normal at a set of barycentric coordinates.
Public methodNormalAt(Int32, Double, Double, Double, Double)
Evaluate a mesh normal at a set of barycentric coordinates. Barycentric coordinates must be assigned in accordance with the rules as defined by MeshPoint.T.
Public methodOffset(Double)
Makes a new mesh with vertices offset a distance in the opposite direction of the existing vertex normals. Same as Mesh.Offset(distance, false)
Public methodOffset(Double, Boolean)
Makes a new mesh with vertices offset a distance in the opposite direction of the existing vertex normals. Optionally, based on the value of solidify, adds the input mesh and a ribbon of faces along any naked edges. If solidify is false it acts exactly as the Offset(distance) function.
Public methodOffset(Double, Boolean, Vector3d)
Makes a new mesh with vertices offset a distance along the direction parameter. Optionally, based on the value of solidify, adds the input mesh and a ribbon of faces along any naked edges. If solidify is false it acts exactly as the Offset(distance) function.
Public methodOffset(Double, Boolean, Vector3d, ListInt32)
Makes a new mesh with vertices offset a distance along the direction parameter. Optionally, based on the value of solidify, adds the input mesh and a ribbon of faces along any naked edges. If solidify is false it acts exactly as the Offset(distance) function. Returns list of wall faces, i.e. the faces that connect original and offset mesh when solidified.
Protected methodOnSwitchToNonConst
Performs some memory cleanup if necessary
(Overrides GeometryBaseOnSwitchToNonConst.)
Public methodPointAt(MeshPoint)
Evaluate a mesh at a set of barycentric coordinates.
Public methodPointAt(Int32, Double, Double, Double, Double)
Evaluates a mesh at a set of barycentric coordinates. Barycentric coordinates must be assigned in accordance with the rules as defined by MeshPoint.T.
Public methodPullCurve
Gets a polyline approximation of the input curve and then moves its control points to the closest point on the mesh. Then it "connects the points" over edges so that a polyline on the mesh is formed.
Public methodPullPointsToMesh
Pulls a collection of points to a mesh.
Public methodQuadRemesh(QuadRemeshParameters)
Quad remesh this mesh.
Public methodQuadRemesh(QuadRemeshParameters, IEnumerableCurve)
Quad remesh this mesh.
Public methodQuadRemeshAsync(QuadRemeshParameters, IProgressInt32, CancellationToken)
Quad remesh this mesh asynchronously.
Public methodQuadRemeshAsync(QuadRemeshParameters, IEnumerableCurve, IProgressInt32, CancellationToken)
Quad remesh this mesh asynchronously.
Public methodQuadRemeshAsync(IEnumerableInt32, QuadRemeshParameters, IEnumerableCurve, IProgressInt32, CancellationToken)
Quad remesh this mesh asynchronously.
Public methodStatic memberQuadRemeshBrep(Brep, QuadRemeshParameters)
Create QuadRemesh from a Brep Set Brep Face Mode by setting QuadRemeshParameters.PreserveMeshArrayEdgesMode
Public methodStatic memberQuadRemeshBrep(Brep, QuadRemeshParameters, IEnumerableCurve)
Create Quad Remesh from a Brep
Public methodStatic memberQuadRemeshBrepAsync(Brep, QuadRemeshParameters, IProgressInt32, CancellationToken)
Quad remesh this Brep asynchronously.
Public methodStatic memberQuadRemeshBrepAsync(Brep, QuadRemeshParameters, IEnumerableCurve, IProgressInt32, CancellationToken)
Quad remesh this Brep asynchronously.
Public methodRebuildNormals
Removes mesh normals and reconstructs the face and vertex normals based on the orientation of the faces.
Public methodReduce(ReduceMeshParameters)
Reduce polygon count
Public methodReduce(ReduceMeshParameters, Boolean)
Reduce polygon count
Public methodReduce(Int32, Boolean, Int32, Boolean)
Reduce polygon count
Public methodReduce(Int32, Boolean, Int32, Boolean, Boolean)
Reduce polygon count
Public methodReduce(Int32, Boolean, Int32, Boolean, CancellationToken, IProgressDouble, String)
Reduce polygon count
Public methodReduce(Int32, Boolean, Int32, Boolean, CancellationToken, IProgressDouble, String, Boolean)
Reduce polygon count
Public methodReleaseUnsafeLock
Updates the Mesh data with the information that was stored via the MeshUnsafeLock.
Public methodStatic memberRequireIterativeCleanup
Analyzes some meshes, and determines if a pass of CreateFromIterativeCleanup would change the array.

All available cleanup steps are used. Currently available cleanup steps are:

- mending of single precision coincidence even though double precision vertices differ.

- union of nearly identical vertices, irrespectively of their origin.

- removal of t-joints along edges.

Public methodSetCachedTextureCoordinates
Set cached texture coordinates using the specified mapping.
Public methodSetTextureCoordinates(TextureMapping, Transform, Boolean)
Set texture coordinates using given mapping and applying given transform. Set lazy to false to generate texture coordinates right away.
Public methodSetTextureCoordinates(TextureMapping, Transform, Boolean, Boolean)
Set texture coordinates using given mapping and applying given transform. Set lazy to false to generate texture coordinates right away.
Public methodSmooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem)
Smooths a mesh by averaging the positions of mesh vertices in a specified region.
Public methodSmooth(Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem, Plane)
Smooths a mesh by averaging the positions of mesh vertices in a specified region.
Public methodSmooth(IEnumerableInt32, Double, Boolean, Boolean, Boolean, Boolean, SmoothingCoordinateSystem, Plane)
Smooths part of a mesh by averaging the positions of mesh vertices in a specified region.
Public methodSolidOrientation
Determines orientation of a "solid" mesh.
Public methodSplit(Mesh)
Split a mesh with another mesh. Suggestion: upgrade to overload with tolerance.
Public methodSplit(IEnumerableMesh)
Split a mesh with a collection of meshes. Suggestion: upgrade to overload with tolerance. Does not split at coplanar intersections.
Public methodSplit(Plane)
Split a mesh by an infinite plane.
Public methodSplit(IEnumerableMesh, Double, Boolean, TextLog, CancellationToken, IProgressDouble)
Split a mesh with a collection of meshes.
Public methodSplit(IEnumerableMesh, Double, Boolean, Boolean, TextLog, CancellationToken, IProgressDouble)
Split a mesh with a collection of meshes.
Public methodSplitDisjointPieces
Splits up the mesh into its unconnected pieces.
Public methodSplitWithProjectedPolylines(IEnumerablePolylineCurve, Double)
Splits a mesh by adding edges in correspondence with input polylines, and divides the mesh at partitioned areas. Polyline segments that are measured not to be on the mesh will be ignored.
Public methodSplitWithProjectedPolylines(IEnumerablePolylineCurve, Double, TextLog, CancellationToken, IProgressDouble)
Splits a mesh by adding edges in correspondence with input polylines, and divides the mesh at partitioned areas. Polyline segments that are measured not to be on the mesh will be ignored.
Public methodUnifyNormals
Attempts to fix inconsistencies in the directions of mesh faces in a mesh. This function does not modify mesh vertex normals, it rearranges the mesh face winding and face normals to make them all consistent. Note, you may want to call Mesh.Normals.ComputeNormals() to recompute vertex normals after calling this functions.
Public methodUnifyNormals(Boolean)
Attempts to fix inconsistencies in the directions of mesh faces in a mesh. This function does not modify mesh vertex normals, it rearranges the mesh face winding and face normals to make them all consistent. Note, you may want to call Mesh.Normals.ComputeNormals() to recompute vertex normals after calling this functions.
Public methodUnweld
Makes sure that faces sharing an edge and having a difference of normal greater than or equal to angleToleranceRadians have unique vertexes along that edge, adding vertices if necessary.
Public methodUnweldEdge
Adds creases to a smooth mesh by creating coincident vertices along selected edges.
Public methodUnweldVertices
Ensures that faces sharing a common topological vertex have unique indices into the MeshVertexList collection.
Public methodVolume
Compute volume of the mesh.
Public methodWeld
Makes sure that faces sharing an edge and having a difference of normal greater than or equal to angleToleranceRadians share vertexes along that edge, vertex normals are averaged.
Public methodWithDisplacement
Constructs new mesh from the current one, with displacement applied to it.
Public methodWithEdgeSoftening
Constructs new mesh from the current one, with edge softening applied to it.
Public methodWithShutLining
Constructs new mesh from the current one, with shut lining applied to it.
Top
See Also