RhinoCommon API
MeshUnsafeLock Class |
Permits access to the underlying mesh raw data structures in an unsafe way.

Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)

The MeshUnsafeLock type exposes the following members.

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) |
![]() | FacesArray |
Retrieves a pointer to the raw faces array, which uses 4 integers for each face.
MeshFace.
|
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object.) |
![]() | NormalVector3fArray |
Retrieves a pointer to the raw mesh vertex normal array, which uses vectors
defined with single precision floating point numbers, or throws an exception if none is available.
|
![]() | Release |
Releases the lock and updates the underlying unmanaged data structures.
|
![]() | ToString | Returns a string that represents the current object. (Inherited from Object.) |
![]() | VertexPoint3dArray |
Retrieves a pointer to the raw mesh vertex array, which uses coordinates
defined with double precision floating point numbers, or throws an exception if none is available.
|
![]() | VertexPoint3fArray |
Retrieves a pointer to the raw mesh vertex array, which uses coordinates
defined with single precision floating point numbers, or null if none is available.
|

This lock object needs to be disposed before using the Mesh in other calculations and this can
be achieved with the using keyword (Using in VB.Net).