RhinoCommon API
MeshUnsafeLockFacesArray Method |
Retrieves a pointer to the raw faces array, which uses 4 integers for each face.
MeshFace.
Namespace: Rhino.Geometry
Assembly: RhinoCommon (in RhinoCommon.dll)
Since: 6.20

Parameters
- length
- Type: SystemInt32
The length of the array. This value is returned by reference (out in C#).
Return Value
Type: MeshFace*The beginning of the vertex array. Item 0 is the first vertex, and item length-1 is the last valid one.

Exception | Condition |
---|---|
InvalidOperationException | The mesh does not have face normals. |