Mesh.CreateFromCurveExtrusion Method

MeshCreateFromCurveExtrusion Method

Constructs a new extrusion from a curve.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.0
Syntax
public static Mesh CreateFromCurveExtrusion(
	Curve curve,
	Vector3d direction,
	MeshingParameters parameters,
	BoundingBox boundingBox
)
Public Shared Function CreateFromCurveExtrusion ( 
	curve As Curve,
	direction As Vector3d,
	parameters As MeshingParameters,
	boundingBox As BoundingBox
) As Mesh

Parameters

curve
Type: Rhino.GeometryCurve
A curve to extrude.
direction
Type: Rhino.GeometryVector3d
The direction of extrusion.
parameters
Type: Rhino.GeometryMeshingParameters
The parameters of meshing.
boundingBox
Type: Rhino.GeometryBoundingBox
The bounding box controls the length of the extrusion.

Return Value

Type: Mesh
A new mesh, or null on failure.
See Also