RenderContent.RenderHashExclude Method (CrcRenderHashFlags, String, LinearWorkflow)

RenderContentRenderHashExclude Method (CrcRenderHashFlags, String, LinearWorkflow)

As RenderHash, but ignore parameter names given. Use this version of the function to calculate a render hash when you have the linear workflow information and you are not running on the main thread. Access to LinearWorkflow data requires document access. CrcRenderHashFlags.ExcludeLinearWorkflow must be specified.

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.2
Syntax
public uint RenderHashExclude(
	CrcRenderHashFlags flags,
	string excludeParameterNames,
	LinearWorkflow lw
)
Public Function RenderHashExclude ( 
	flags As CrcRenderHashFlags,
	excludeParameterNames As String,
	lw As LinearWorkflow
) As UInteger

Parameters

flags
Type: Rhino.RenderCrcRenderHashFlags
Flags to ignore
excludeParameterNames
Type: SystemString
semicolon-delimited string
lw
Type: Rhino.RenderLinearWorkflow
Linear Workflow to use for CRC

Return Value

Type: UInt32
Render hash
See Also