Rhino.Render Namespace

Rhino.Render Namespace

[Missing <summary> documentation for "N:Rhino.Render"]

Classes
  ClassDescription
Public classAsyncRenderContext
\ingroup rhino_render Inherit from AsyncRenderContext to be able to create asynchronous render engine implementations through RhinoCommon.
Public classCachedTextureCoordinates
Used for cached texture coordinates
Public classCity
City
Public classContentCollectionIterator
Public classContentUndoBlocker
Public classContentUndoHelper
Content undo helper to be used with "using {}" to enclose a block of changes.
Public classContentUuids
Content Guids of RenderContent provided by the RDK SDK. These Guids can be used to check against RenderContent.TypeId.
Public classConvertibleExtensions
Extension methods for IConvertible that work when an object is a Variant.
Public classCreatePreviewEventArgs
Used in RenderPlugIn virtual CreatePreview function
Public classCreatePreviewEventArgsSceneObject
Public classCreateTexture2dPreviewEventArgs
Public classCustomRenderContentAttribute
Public classCustomRenderMeshProvider Obsolete.
You must call CustomRenderMeshProvider.RegisterProviders() from your plug-ins OnLoad override for each assembly containing a custom mesh provider. Only publicly exported classes derived from CustomRenderMeshProvider with a public constructor that has no parameters will get registered.
Public classCustomRenderMeshProvider2
Public classDecal
Represents a decal, or a picture that can be moved on an object.
Public classDecalCreateParams
Used by RhinoObject.AddDecal() to create and add a decal
Public classDecals
Represents all the decals of an object.
Public classDithering
This is the interface to linear workflow settings.
Public classDocumentOrFreeFloatingBase
Base class for Rhino.Render objects that are owned by the document, or can be delivered separately from other functions. In general, you cannot create these objects yourself.
Public classFreeFloatingBase
Base class for Rhino.Render objects that are owned by the document, or can be delivered separately from other functions. In general, you cannot create these objects yourself.
Public classGroundPlane
Represents an infinite plane for implementation by renderers. See SupportsFeature.
Public classImageFile
Controls interaction with RDK render image files
Public classImageFileEventArgs
Public classLightArray
Public classLightManagerSupport
Base class for implementing custom light managers in .NET
Public classLightManagerSupportClient
Public classLinearWorkflow
This is the interface to linear workflow settings.
Public classMappingTag
Holds texture mapping information.
Public classMetaDataProxy
ProxyClass for MetaData
Public classNamedValue
Public classPhysicallyBasedMaterial Obsolete.
Public classPhysicallyBasedMaterialParametersNames Obsolete.
Helper class with fields containing the names of fields available in our PBR implementation.
Public classPixelBuffer
Public classPreviewAppearance
PreviewAppearance class
Public classPreviewBackground
PreviewBackGround takes care of constucting and desctrutction of PreviewLight
Public classPreviewGeometry
PreviewAppearance takes care of constucting and desctrutction of PreivewGeometry
Public classPreviewLighting
PreviewAppearance takes care of constucting and desctrutction of PreviewLight
Public classPreviewSceneServer
PreviewSceneServer
Public classRdkUndo
RdkUndo class, which is used to get the RdkUndoRecord
Public classRdkUndoRecord
RdkUndoRecord class
Public classRealtimeDisplayMode
Base class for implementing real-time display modes in .NET. Pay special attention that in StartRenderer the RenderWindow.SetSize() function is called if the implementation relies on the RenderWindow to do the drawing to the viewport. If i.e. OpenGL is used to draw render results to the viewport then SetSize() doesn't have to be called, nor should the implementation then access channels on the RenderWindow, as those then don't exist. For OpenGL-based drawing the RenderWindow is used as a container for ViewInfo management, nothing else.
Public classRealtimeDisplayModeDisplayPipelineSettingsChangedEventArgs
Public classRealtimeDisplayModeDrawMiddlegroundEventArgs
Public classRealtimeDisplayModeHudMaxPassesChangedEventArgs
Public classRealtimeDisplayModeInitFramebufferEventArgs
Public classRealtimeDisplayModeClassInfo
Class information obligatory for registering RealtimeDisplayMode implementations.
Public classRenderChannels
Render Channels. This corresponds to the user's settings in the Rendering panel.
Public classRenderContent
Public classRenderContentChangedEventArgs
Public classRenderContentCollection
Public classRenderContentEventArgs
Public classRenderContentFieldChangedEventArgs
Public classRenderContentKindList
Public classRenderContentManager
RenderContentManager's RestoreRenderContents method unpacks the default render contents from the from the application and places them in the User's folder. Only available on Mac at the moment.
Public classRenderContentSerializer
Used to import and export custom render content such as materials, environments and textures. You must override RenderPlugIn.RenderContentSerializers() and return an array of derived RenderContentSerializer class types to add to the content browsers.
Public classRenderContentType
Represents one of the render content types registered with Rhino.
Public classRenderEndEventArgs
Contains information about why OnRenderEnd was called
Public classRenderEnvironment
Public classRenderEnvironmentTable
Public classRenderMaterial
Public classRenderMaterialBasicMaterialParameterNames
Parameter names for use in GetNamedParameter and SetNamedParameter with basic materials.
Public classRenderMaterialTable
Public classRenderPanels
This class is used to extend the standard Render user interface
Public classRenderPipeline
Provides facilities to a render plug-in for integrating with the standard Rhino render window. Also adds helper functions for processing a render scene. This is the suggested class to use when integrating a renderer with Rhino and maintaining a "standard" user interface that users will expect.
Public classRenderPlugInInfo
Public classRenderPlugInList
Public classRenderPrimitive
Public classRenderPrimitiveList
Public classRenderPropertyChangedEvent
Used by Rhino.Render object property value has changed events.
Public classRenderSettings
Contains settings used in rendering.
Public classRenderSourceView
Helper class to get the correct view from the Render View Source settings. An instance of this class is supposed to be used with the using() {} construct.
Public classRenderTabs
Public classRenderTexture
Public classRenderTextureTable
Public classRenderWindow
Public classRenderWindowChannel
Public classRenderWindowChannelGPU
Public classRenderWindowImageAdjust
Class to set image adjusting settings to a RenderWindow. This can't be directly created. Instead, one should use RenderWindow.GetAdjust() to get an ImageAdjust instance that can be modified, then passed into RenderWindow.SetAdjust() to update image adjusting settings.1
Public classRenderWindowClonedEventArgs
Public classSceneServerData
The Scene Server Data used by the PreviewSceneServer
Public classSimulatedEnvironment
Public classSimulatedTexture
Public classSkylight
Public classSun
Represents the Sun on a little portion of Earth.
Public classSupportOptions
Public classTexturedColor
Color4f specialization of TexturedValue.
Public classTexturedFloat
float specialization of TexturedValue.
Public classTexturedValueT
Generic class to help holding on to related values. This can be used to get data from textured content fields with the HandleTexturedValue function.
Public classTextureEvaluator
This is the interface to a lightweight object capable of evaluating texture color throughout uvw space. Derive from this class to create your own texture evaluator to return from a custom RenderTexture.
Public classTextureGraphInfo
Public classTextureMapping
Represents a texture mapping.
Public classTimeZone
TimeZone
Public classTwoColorRenderTexture
Public classUndoRedo
This class contains the event for UndoRedoChanged that is fired from RDK .
Public classUtilities
Interfaces
Enumerations
  EnumerationDescription
Public enumerationComponentOrders
Pixel component order for channels in the RenderWindow and PostEffects.
Public enumerationCrcRenderHashFlags
Public enumerationCreatePreviewReason
Reason the content preview is being generated
Public enumerationDecalMapping
Public enumerationDecalProjection
Public enumerationDitheringMethods
Dithering algorithm.
Public enumerationDynamicIconUsage
Public enumerationFilterContentByUsage
Content collection filter value
Public enumerationImageFileEvent
Public enumerationIRhRdkPreviewSceneServer_eRotationType
c# version of IRhRdkPreviewSceneServer eRotationType enum
Public enumerationit_strategy
Defines the collection type to iterate.
Public enumerationLightMangerSupportCustomEvent
LightMangerSupportCustomEvent
Public enumerationPreviewSceneQuality
Quality levels when creating preview images
Public enumerationProxyTypes
Defines the proxy type of the render content
Public enumerationRenderChannelsModes
Mode.
Public enumerationRenderContentChangeContexts
Context of a change to content parameters.
Public enumerationRenderContentExtraRequirementsSetContexts
Public enumerationRenderContentMatchDataResult
Return values for MatchData function
Public enumerationRenderContentShowContentChooserFlags
Public enumerationRenderContentChangeReason
Enumeration denoting type of change for attach or detach
Public enumerationRenderContentKind
Defines constant values for all render content kinds, such as material, environment or texture.
Public enumerationRenderContentSerializerLoadMultipleFlags
Public enumerationRenderContentStyles
Public enumerationRenderEnvironmentUsage
Public enumerationRenderMaterialPreviewBackgroundType
The default scene background for the image that appears in preview panes
Public enumerationRenderMaterialPreviewGeometryType
Geometry that appears in preview panes
Public enumerationRenderMaterialStandardChildSlots
Defines enumerated constant values for use in TextureChildSlotName(RenderMaterialStandardChildSlots) method. NOTE WELL - these values cannot be changed. https://mcneel.myjetbrains.com/youtrack/issue/RH-57752
Public enumerationRenderPanelType
Contains the custom user interfaces that may be provided
Public enumerationRenderPipelineRenderReturnCode
Public enumerationRenderPrimitiveType
Public enumerationRenderSettingsRenderingSources
Rendering source (render directly from a NamedView or Snapshot)
Public enumerationRenderTextureeLocalMappingType
Public enumerationRenderTextureTextureEvaluatorFlags
Public enumerationRenderTextureTextureGeneration
Public enumerationRenderWindowRenderSuccessCode
Public enumerationRenderWindowStandardChannels
Public enumerationSceneServerDataUsage
SceneServerData Usage (Synchronous or Asynchronous)
Public enumerationSimulatedEnvironmentBackgroundProjections
Public enumerationSimulatedTextureEnvironmentMappingModes
Public enumerationSimulatedTextureProjectionModes
Public enumerationSupportOptionsRdkInitialLocation
Public enumerationSupportOptionsRdkTextureSize
Public enumerationTextureEnvironmentMappingMode
Public enumerationTextureGeneration
Public enumerationTextureGraphInfoAxis
Public enumerationTextureGraphInfoChannel
Public enumerationTextureMappingType
Defines enumerated constants for mapping types such as planar, cylindrical or spherical.
Public enumerationTextureMode
Public enumerationTextureProjectionMode
Public enumerationTextureRenderHashFlags
Public enumerationTextureWrapType
Public enumerationUtilitiesShowContentChooserResults