RenderSettings Class

RenderSettings Class

Contains settings used in rendering.
Inheritance Hierarchy
SystemObject
  Rhino.RuntimeCommonObject
    Rhino.RenderRenderSettings

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class RenderSettings : CommonObject
Public Class RenderSettings
	Inherits CommonObject

The RenderSettings type exposes the following members.

Constructors
  NameDescription
Public methodRenderSettings
Initialize a new instance of the RenderSettings class.
Public methodRenderSettings(RenderSettings)
Initialize new instance of the RenderSettings class.
Top
Properties
  NameDescription
Public propertyAmbientLight
Gets or sets the ambient light color used in rendering.
Public propertyAntialiasLevel
Gets or sets anti-alias level, used for render quality
Public propertyBackgroundColorBottom
Gets or sets the background bottom color used in rendering.
Public propertyBackgroundColorTop
Gets or sets the background top color used in rendering.

Sets also the background color if a solid background color is set.

Public propertyBackgroundStyle
How the viewport's background should be filled.
Public propertyDepthCue
Gets or sets a value indicating whether to render using depth cues.

These are clues to help the perception of position and orientation of objects in the image.

Public propertyDithering
Get the document dithering interface
Public propertyFlatShade
Gets or sets a value indicating whether to render using flat shading.
Public propertyImageDpi
Number of dots/inch (dots=pixels) to use when printing and saving bitmaps. The default is 72.0 dots/inch.
Public propertyImageSize
Gets or sets a value indicating the size of the rendering result if UseViewportSize is set to false. If UseViewportSize is set to true, then this value is ignored.
Public propertyImageUnitSystem
unit system to use when converting image pixel size and DPI information into a print size. Default = inches
Public propertyLinearWorkflow
Get the document linear workflow interface
Public propertyNamedView
Get or set the given named view
Public propertyRenderAnnotations
Gets or sets a value indicating whether to instruct the rendering engine to show annotations, such as linear dimensions or angular dimensions.
Public propertyRenderBackfaces
Gets or sets a value indicating whether to render back faces.
Public propertyRenderChannels
Get the document render channels interface
Public propertyRenderCurves
Gets or sets a value indicating whether to instruct the rendering engine to show curves.
Public propertyRenderIsoparams
Gets or sets a value indicating whether to instruct the rendering engine to show isocurves.
Public propertyRenderMeshEdges
Gets or sets a value indicating whether to instruct the rendering engine to show mesh edges.
Public propertyRenderPoints
Gets or sets a value indicating whether to instruct the rendering engine to show points.
Public propertyRenderSource
Gets or sets the render source RenderSettingsRenderingSources enumeration.
Public propertyScaleBackgroundToFit
Gets or sets a value indicating whether to scale the wallpaper in the background or not. This is meaningful only if the viewport has a wallpaper and render settings are set to render Wallpaper into the background.
Public propertyShadowmapLevel
0=none, 1=normal, 2=best.
Public propertySnapshot
Set or get the given snapshot view
Public propertySpecificViewport
Set or get the given specific viewport
Public propertyTransparentBackground
Gets or sets whether rendering should be done with transparent background.
Public propertyUseHiddenLights
Gets or sets a value indicating whether to render using lights that are on layers that are off.
Public propertyUseViewportSize
Gets or sets a value indicating whether to use the resolution of the viewport being rendered or ImageSize when rendering
Top
Methods
  NameDescription
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Top
See Also