RenderTabs Class

RenderTabs Class

[Missing <summary> documentation for "T:Rhino.Render.RenderTabs"]

Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderTabs

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class RenderTabs
Public NotInheritable Class RenderTabs

The RenderTabs type exposes the following members.

Methods
  NameDescription
Public methodStatic memberFromRenderSessionId
Get the instance of a render tab associated with a specific render session, this is useful when it is necessary to update a control from a RenderPipeline
Public methodRegisterTab(PlugIn, Type, String, Icon) Obsolete.
Register custom render user interface with Rhino. This should only be done in RegisterRenderTabs(RenderTabs). Panels registered after RegisterRenderTabs(RenderTabs) is called will be ignored. If the class includes a public method "void DoHelp()" the method will get called when F1 is pressed and the custom tab is active.
Public methodRegisterTab(PlugIn, Type, Guid, String, Icon)
Public methodStatic memberSessionIdFromTab
Get the session Id that created the specified tab object.
Top
See Also