CustomRenderMeshProvider2 Class |
[Missing <summary> documentation for "T:Rhino.Render.CustomRenderMeshProvider2"]
Inheritance Hierarchy
Namespace:
Rhino.Render
Assembly:
RhinoCommon (in RhinoCommon.dll)
Syntaxpublic abstract class CustomRenderMeshProvider2 : CustomRenderMeshProvider
Public MustInherit Class CustomRenderMeshProvider2
Inherits CustomRenderMeshProvider
The CustomRenderMeshProvider2 type exposes the following members.
Constructors
Properties
Methods
| Name | Description |
---|
 | BoundingBox(ViewportInfo, RhinoObject, Guid, Boolean) | (Overrides CustomRenderMeshProviderBoundingBox(ViewportInfo, RhinoObject, Guid, Boolean).) |
 | BoundingBox(ViewportInfo, RhinoObject, RhinoDoc, Guid, DisplayPipelineAttributes) | |
 | BuildCustomMeshes(ViewportInfo, RenderPrimitiveList, Guid, Boolean) | (Overrides CustomRenderMeshProviderBuildCustomMeshes(ViewportInfo, RenderPrimitiveList, Guid, Boolean).) |
 | BuildCustomMeshes(ViewportInfo, RhinoDoc, RenderPrimitiveList, Guid, DisplayPipelineAttributes) | |
 | WillBuildCustomMeshes(ViewportInfo, RhinoObject, Guid, Boolean) | (Overrides CustomRenderMeshProviderWillBuildCustomMeshes(ViewportInfo, RhinoObject, Guid, Boolean).) |
 | WillBuildCustomMeshes(ViewportInfo, RhinoObject, RhinoDoc, Guid, DisplayPipelineAttributes) | |
Top
See Also