Decal Class

Decal Class

Represents a decal, or a picture that can be moved on an object.
Inheritance Hierarchy
SystemObject
  Rhino.RenderDecal

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class Decal : IDisposable
Public Class Decal
	Implements IDisposable

The Decal type exposes the following members.

Properties
  NameDescription
Public propertyCRC
The decal CRC identifies a decal by its state. Multiple decals which would be exactly the same would have the same CRC and are culled from the system. If you store this value with the intention of using it to find the decal again later, you must update your stored value whenever the decal state changes. You can detect when a decal changes by watching for the OnUserDataTransformed event.
Public propertyDecalMapping
Gets the mapping of the decal.
Public propertyDecalProjection
Gets the decal's projection. Used only when mapping is planar.
Public propertyEndLatitude
Gets the end angle of the decal's arc of latitude or 'horizontal sweep'. This is actually a LONGITUDINAL angle. Only used when mapping is cylindrical or spherical.
Public propertyEndLongitude
Gets the end angle of the decal's arc of longitude or 'vertical sweep'. This is actually a LATITUDINAL angle. Only used when mapping is spherical.
Public propertyHeight
Gets the height of the decal. Only used when mapping is cylindrical.
Public propertyMapToInside
Used only when mapping is cylindrical or spherical.
Public propertyOrigin
Gets the origin of the decal in world space.
Public propertyRadius
Gets the radius of the decal. Only used when mapping is cylindrical or spherical.
Public propertyStartLatitude
Gets the start angle of the decal's arc of latitude or 'horizontal sweep'. This is actually a LONGITUDINAL angle. Only used when mapping is cylindrical or spherical.
Public propertyStartLongitude
Gets the start angle of the decal's arc of longitude or 'vertical sweep'. This is actually a LATITUDINAL angle. Only used when mapping is spherical.
Public propertyTextureInstanceId
Gets the texture ID for this decal.
Public propertyTransparency
Gets the decal's transparency in the range 0 to 1.
Public propertyVectorAcross
Gets the vector across. For cylindrical and spherical mapping, the vector is unitized.
Public propertyVectorUp
For cylindrical and spherical mapping, the vector is unitized.
Top
Methods
  NameDescription
Public methodConstPointer
Public methodStatic memberCreate
Public methodCustomData
Gets custom data associated with this decal - see Rhino.Plugins.RenderPlugIn.ShowDecalProperties.
Public methodDispose
Releases all resources used by the Decal
Public methodDispose(Boolean)
Releases the unmanaged resources used by the Decal and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetTextureMapping
The TextureMapping of the decal.
Public methodNonConstPointer
Public methodTextureRenderCRC(TextureRenderHashFlags)
Get the texture render CRC for the referenced texture using the TextureRenderHashFlags given
Public methodTextureRenderCRC(TextureRenderHashFlags, LinearWorkflow)
Get the texture render CRC for the referenced texture using the TextureRenderHashFlags given along with the LinearWorkflow
Public methodTryGetColor
Blend color with the decal color at a given point.
Public methodUVBounds
The UV bounds of the decal. Only used when mapping is UV.
Top
See Also