RenderContentCollection Class

RenderContentCollection Class

[Missing <summary> documentation for "T:Rhino.Render.RenderContentCollection"]

Inheritance Hierarchy
SystemObject
  Rhino.RenderRenderContentCollection

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class RenderContentCollection : IDisposable, 
	IEnumerable
Public NotInheritable Class RenderContentCollection
	Implements IDisposable, IEnumerable

The RenderContentCollection type exposes the following members.

Constructors
  NameDescription
Public methodRenderContentCollection
Initializes a new instance of the RenderContentCollection class
Public methodRenderContentCollection(IntPtr)
Initializes a new instance of the RenderContentCollection class
Top
Properties
  NameDescription
Public propertyCppPointer
Top
Methods
  NameDescription
Public methodAdd
Public methodAppend
Public methodClear
Public methodContentAt
Public methodContentNeedsPreviewThumbnail
Public methodCount
Public methodDispose
Releases all resources used by the RenderContentCollection
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodFind_Sel
Public methodFirstTag
Public methodGetEnumerator
Public methodGetFilterContentByUsage
Public methodGetForcedVaries
Public methodGetSearchPattern
Public methodIterator
Public methodNextTag
Public methodRemove
Public methodSet
Public methodSetForcedVaries
Public methodSetSearchPattern
Top
See Also