DocumentOrFreeFloatingBase Class

DocumentOrFreeFloatingBase Class

Base class for Rhino.Render objects that are owned by the document, or can be delivered separately from other functions. In general, you cannot create these objects yourself.
Inheritance Hierarchy
SystemObject
  Rhino.RenderFreeFloatingBase
    Rhino.RenderDocumentOrFreeFloatingBase
      More...

Namespace:  Rhino.Render
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class DocumentOrFreeFloatingBase : FreeFloatingBase
Public MustInherit Class DocumentOrFreeFloatingBase
	Inherits FreeFloatingBase

The DocumentOrFreeFloatingBase type exposes the following members.

Methods
  NameDescription
Public methodBeginChange
Call this function before making any change to this object (calling a setter) otherwise undo will not work correctly. Calls to BeginChange must be paired with a call to EndChange.
Public methodEndChange
See BeginChange
Top
See Also
Inheritance Hierarchy
SystemObject
  Rhino.RenderFreeFloatingBase
    Rhino.RenderDocumentOrFreeFloatingBase
      Rhino.RenderDithering
      Rhino.RenderGroundPlane
      Rhino.RenderLinearWorkflow
      Rhino.RenderRenderChannels
      Rhino.RenderSkylight
      Rhino.RenderSun