Occurs when an error occurs during the lifetime of a
Progress object.
For example, if an error occurs whilst opening a large file the error
can be displayed to the user who is offered the chance to cancel.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Examples
CopyProgress Events
Autodesk.Navisworks.Api.Application.ProgressBeginning += new EventHandler<Autodesk.Navisworks.Api.ProgressBeginningEventArgs>(Application_ProgressBeginning);
Autodesk.Navisworks.Api.Application.ProgressSubOperationBegan += new EventHandler<Autodesk.Navisworks.Api.ProgressSubOperationBeganEventArgs>(Application_ProgressSubOperationBegan);
Autodesk.Navisworks.Api.Application.ProgressUpdating += new EventHandler<Autodesk.Navisworks.Api.ProgressUpdatingEventArgs>(Application_ProgressUpdating);
Autodesk.Navisworks.Api.Application.ProgressErrorReporting += new EventHandler<Autodesk.Navisworks.Api.ProgressErrorReportingEventArgs>(Application_ProgressErrorReporting);
Autodesk.Navisworks.Api.Application.ProgressMessageReporting += new EventHandler<Autodesk.Navisworks.Api.ProgressMessageReportingEventArgs>(Application_ProgressMessageReporting);
Autodesk.Navisworks.Api.Application.ProgressSubOperationEnded += new EventHandler<Autodesk.Navisworks.Api.ProgressSubOperationEndedEventArgs>(Application_ProgressSubOperationEnded);
Autodesk.Navisworks.Api.Application.ProgressEnded += new EventHandler<Autodesk.Navisworks.Api.ProgressEndedEventArgs>(Application_ProgressEnded);
progressBar.ProgressBar.Maximum = 100;
void Application_ProgressErrorReporting(object sender, Autodesk.Navisworks.Api.ProgressErrorReportingEventArgs e)
{
if (MessageBox.Show(e.Message, "Error", MessageBoxButtons.OKCancel) != DialogResult.OK)
{
e.Canceled = true;
}
e.Handled = true;
statusStrip.Refresh();
}
See Also