|
![]() |
Used to report progress of lengthy operations
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Class Progress _ Inherits NativeHandle |
C# |
---|
public class Progress : NativeHandle |
Visual C++ |
---|
public ref class Progress : public NativeHandle |
Remarks
When instantiated a progress bar in the Navisworks style is displayed to the user inside the Navisworks main application. This can then be updated by the program or plugin with textual information as well as the percentage completed of the process.
Examples

/// <summary> /// Shows the basic concept of using the Progress class /// </summary> private static void SimpleProgressExample() { //first get reference to an instance of the Progress class Progress progress = Autodesk.Navisworks.Api.Application.BeginProgress(); double stage; for (stage = 0.0; stage < 1.0; stage += 0.1) { //Update progress bar progress.Update(stage); //Do something for a period of time System.Threading.Thread.Sleep(1000); } //Update progress bar to 100% progress.Update(1.0); //notify the API that the operation has finished Autodesk.Navisworks.Api.Application.EndProgress(); }