Updates progress on the current operation or sub-operation
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Function Update ( _
fractionDone As Double _
) As Boolean |
Visual C++ |
---|
public:
bool Update(
double fractionDone
) |
Parameters
- fractionDone
- Type: System..::..Double
Fraction of operation or sub-operation completed, between 0 and 1
Return Value
false if user wants to cancel operation, true if they want to continue.
Remarks
Examples
CopyUsing a Progress object
private static void SimpleProgressExample()
{
Progress progress = Autodesk.Navisworks.Api.Application.BeginProgress();
double stage;
for (stage = 0.0; stage < 1.0; stage += 0.1)
{
progress.Update(stage);
System.Threading.Thread.Sleep(1000);
}
progress.Update(1.0);
Autodesk.Navisworks.Api.Application.EndProgress();
}
Exceptions
See Also