|
![]() |
Provides an instance of the Progress class
which starts reporting of progress of an operation, typically displaying a progress bar
or dialog to the end user.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Remarks
Returns a Progress object which can be used to update the user as to how far a process has run.
Examples

/// <summary> /// Shows the basic concept of using the Progress class /// </summary> private static void SimpleProgressExample() { //first get reference to an instance of the Progress class Progress progress = Autodesk.Navisworks.Api.Application.BeginProgress(); double stage; for (stage = 0.0; stage < 1.0; stage += 0.1) { //Update progress bar progress.Update(stage); //Do something for a period of time System.Threading.Thread.Sleep(1000); } //Update progress bar to 100% progress.Update(1.0); //notify the API that the operation has finished Autodesk.Navisworks.Api.Application.EndProgress(); }