Provides an instance of the
Progress class
which starts reporting of progress of an operation, typically displaying a progress bar
or dialog to the end user.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Shared Function BeginProgress ( _
title As String, _
message As String _
) As Progress |
Parameters
- title
- Type: System..::..String
Title for the overall progress operation (title for Navisworks progress dialog)
- message
- Type: System..::..String
Message describing the current operation (body of Navisworks progress dialog)
Remarks
Examples
CopyUsing a Progress object
private static void SimpleProgressExample()
{
Progress progress = Autodesk.Navisworks.Api.Application.BeginProgress();
double stage;
for (stage = 0.0; stage < 1.0; stage += 0.1)
{
progress.Update(stage);
System.Threading.Thread.Sleep(1000);
}
progress.Update(1.0);
Autodesk.Navisworks.Api.Application.EndProgress();
}
See Also