|
![]() |
Event arguments used for the Application.ProgressMessageReporting event
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Class ProgressMessageReportingEventArgs _ Inherits ProgressEventArgs |
C# |
---|
public class ProgressMessageReportingEventArgs : ProgressEventArgs |
Visual C++ |
---|
public ref class ProgressMessageReportingEventArgs : public ProgressEventArgs |
Remarks
An instance of this class is passed with the Application.ProgressMessageReporting event.
Examples

Autodesk.Navisworks.Api.Application.ProgressBeginning += new EventHandler<Autodesk.Navisworks.Api.ProgressBeginningEventArgs>(Application_ProgressBeginning); Autodesk.Navisworks.Api.Application.ProgressSubOperationBegan += new EventHandler<Autodesk.Navisworks.Api.ProgressSubOperationBeganEventArgs>(Application_ProgressSubOperationBegan); Autodesk.Navisworks.Api.Application.ProgressUpdating += new EventHandler<Autodesk.Navisworks.Api.ProgressUpdatingEventArgs>(Application_ProgressUpdating); Autodesk.Navisworks.Api.Application.ProgressErrorReporting += new EventHandler<Autodesk.Navisworks.Api.ProgressErrorReportingEventArgs>(Application_ProgressErrorReporting); Autodesk.Navisworks.Api.Application.ProgressMessageReporting += new EventHandler<Autodesk.Navisworks.Api.ProgressMessageReportingEventArgs>(Application_ProgressMessageReporting); Autodesk.Navisworks.Api.Application.ProgressSubOperationEnded += new EventHandler<Autodesk.Navisworks.Api.ProgressSubOperationEndedEventArgs>(Application_ProgressSubOperationEnded); Autodesk.Navisworks.Api.Application.ProgressEnded += new EventHandler<Autodesk.Navisworks.Api.ProgressEndedEventArgs>(Application_ProgressEnded); progressBar.ProgressBar.Maximum = 100; //The following are the declarations for controls in a windows form //private System.Windows.Forms.StatusStrip statusStrip; //private System.Windows.Forms.ToolStripStatusLabel statusText; //private System.Windows.Forms.ToolStripProgressBar progressBar; //private System.Windows.Forms.ToolStripStatusLabel statusSubText; void Application_ProgressMessageReporting(object sender, Autodesk.Navisworks.Api.ProgressMessageReportingEventArgs e) { if (statusSubText.Text != e.Message) { statusSubText.Text = e.Message; e.Handled = true; statusStrip.Refresh(); } }
Inheritance Hierarchy
System..::..Object
System..::..EventArgs
Autodesk.Navisworks.Api..::..ProgressEventArgs
Autodesk.Navisworks.Api..::..ProgressMessageReportingEventArgs
System..::..EventArgs
Autodesk.Navisworks.Api..::..ProgressEventArgs
Autodesk.Navisworks.Api..::..ProgressMessageReportingEventArgs