Revit 2024 API |
RebarShapeDrivenAccessor..::..TopFinishingTurns Property |
RebarShapeDrivenAccessor Class See Also |
For a spiral, the number of finishing turns at the upper end of the spiral.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2018
Syntax
C# |
---|
public int TopFinishingTurns { get; set; } |
Visual Basic |
---|
Public Property TopFinishingTurns As Integer Get Set |
Visual C++ |
---|
public: property int TopFinishingTurns { int get (); void set (int value); } |
Remarks
Applies only to instances where RebarShape.Definition is of type
RebarShapeDefinitionByArc, and its Type property is equal to the value
RebarShapeDefinitionByArcType.Spiral.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: turns must be between 0 and 100. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarShapeDrivenAccessor is not an instance of a spiral shape. -or- This RebarShapeDrivenAccessor doesn't contain a valid rebar reference. |