DimensionEqualityLabelFormatting Class

DimensionEqualityLabelFormatting Class

Instances of this class represent individual parameters used to make up a dimension equality formula for continuous linear or angular dimensions.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDimensionEqualityLabelFormatting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DimensionEqualityLabelFormatting : IDisposable
Public Class DimensionEqualityLabelFormatting
	Implements IDisposable
public ref class DimensionEqualityLabelFormatting : IDisposable
type DimensionEqualityLabelFormatting = 
    class
        interface IDisposable
    end

The DimensionEqualityLabelFormatting type exposes the following members.

Constructors
 NameDescription
Public methodDimensionEqualityLabelFormatting Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLabelType The parameter value to be shown.
Public propertyLeadingSpaces The number of spaces to include before the parameter value.
Public propertyPrefix The prefix to include before the parameter value.
Public propertySuffix The suffix to include after the parameter value.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DimensionEqualityLabelFormatting
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetFormatOptions Gets the format options used to show the parameter value.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsValidFormatOptions Checks whether a FormatOptions object is valid for the LabelType.
Public methodSetFormatOptions Sets the format options used to show the parameter value.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also