OBJImportOptions Class

OBJImportOptions Class

The import options used to import OBJ format files.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBaseImportOptions
    Autodesk.Revit.DBOBJImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class OBJImportOptions : BaseImportOptions
Public Class OBJImportOptions
	Inherits BaseImportOptions
public ref class OBJImportOptions : public BaseImportOptions
type OBJImportOptions = 
    class
        inherit BaseImportOptions
    end

The OBJImportOptions type exposes the following members.

Constructors
 NameDescription
Public methodOBJImportOptions Constructs a new instance of OBJImportOptions with default values of all properties.
Public methodOBJImportOptions(OBJImportOptions) Constructs a new instance of OBJImportOptions as a copy of the import options.
Top
Properties
 NameDescription
Public propertyAutoCorrectAlmostVHLines Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
(Inherited from BaseImportOptions)
Public propertyColorMode Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
(Inherited from BaseImportOptions)
Public propertyCustomScale Scaling the import. If this is defined and a valid value (> 0.0), it takes priority over units.
(Inherited from BaseImportOptions)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from BaseImportOptions)
Public propertyOrientToView Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
(Inherited from BaseImportOptions)
Public propertyPlacement Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
(Inherited from BaseImportOptions)
Public propertyReferencePoint The 3D point in the document where the imported instance will be inserted. If not explicitly set, the instance will be inserted at the document origin.
(Inherited from BaseImportOptions)
Public propertyThisViewOnly Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
(Inherited from BaseImportOptions)
Public propertyUnit The unit of measure for imported geometry.
(Inherited from BaseImportOptions)
Public propertyVisibleLayersOnly Only import the visible layers.
(Inherited from BaseImportOptions)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from BaseImportOptions)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetDefaultLengthUnit Get the default length unit used for importing unitless files.
(Inherited from BaseImportOptions)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLayerSelection Get all set layers name which user want to import into Revit.
(Inherited from BaseImportOptions)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetDefaultLengthUnit Set the default length unit used for importing unitless files.
(Inherited from BaseImportOptions)
Public methodSetLayerSelection
(Inherited from BaseImportOptions)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also