IntersectionResult Class

IntersectionResult Class

This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBIntersectionResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class IntersectionResult : APIObject
Public Class IntersectionResult
	Inherits APIObject
public ref class IntersectionResult : public APIObject
type IntersectionResult = 
    class
        inherit APIObject
    end

The IntersectionResult type exposes the following members.

Constructors
 NameDescription
Public methodIntersectionResultInitializes a new instance of the IntersectionResult class
Top
Properties
 NameDescription
Public propertyDistanceDistance from the original object to located point.
Public propertyEdgeObjectEdge of the face close to the point of intersection.
Public propertyEdgeParameterParameter of a point on the edge closest to the point of intersection.
Public propertyParameter1d parameter of the point of intersection.
Public propertyUVPoint2d (or two 1d) parameters of the point of intersection.
Public propertyXYZPointPoint of intersection in local 3d coordinates.
Top
Methods
 NameDescription
Top
See Also