DWFXExportOptions Class

DWFXExportOptions Class

DWFX Export options.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBCADExportOptions
    Autodesk.Revit.DBDWFExportOptions
      Autodesk.Revit.DBDWFXExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DWFXExportOptions : DWFExportOptions
Public Class DWFXExportOptions
	Inherits DWFExportOptions
public ref class DWFXExportOptions : public DWFExportOptions
type DWFXExportOptions = 
    class
        inherit DWFExportOptions
    end

The DWFXExportOptions type exposes the following members.

Constructors
 NameDescription
Public methodDWFXExportOptionsDefault constructor. Sets all options to their default values.
Top
Properties
 NameDescription
Public propertyCropBoxVisibleWhether to export crop box.
(Inherited from DWFExportOptions)
Public propertyExportingAreasWhether to also export areas and rooms' geometry.
(Inherited from DWFExportOptions)
Public propertyExportObjectDataWhether to include properties associated with elements.
(Inherited from DWFExportOptions)
Public propertyExportOnlyViewIdOnly export the specified view.
(Inherited from DWFExportOptions)
Public propertyExportTextureWhether to export texture.
(Inherited from DWFExportOptions)
Public propertyImageFormatControls the compression level of images embedded.
(Inherited from DWFExportOptions)
Public propertyImageQualityImage quality level when compressed raster format(JPEG) is used.
(Inherited from DWFExportOptions)
Public propertyMergedViewsWhether to merge all views in one file.
(Inherited from DWFExportOptions)
Public propertyPaperFormatStandard paper format.
(Inherited from DWFExportOptions)
Public propertyPortraitLayoutPaper orientation - Portrait/Landscape.
(Inherited from DWFExportOptions)
Public propertyStopOnErrorWhether export process should stop when a view fails to export.
(Inherited from DWFExportOptions)
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also