Revit 2025.3 API
Key |
A key-based tree entry, containing the key, parent key, and children keys (if applicable).

SystemObject
Autodesk.Revit.DBKeyBasedTreeEntry
Autodesk.Revit.DBClassificationEntry
Autodesk.Revit.DBKeynoteEntry
Autodesk.Revit.DBKeyBasedTreeEntry
Autodesk.Revit.DBClassificationEntry
Autodesk.Revit.DBKeynoteEntry
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The KeyBasedTreeEntry type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Key | The key of this entry. |
![]() | ParentKey | The parent key of this entry. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the KeyBasedTreeEntry |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetChildrenKeys | Gets a collection containing the keys of all children entry objects from this entry. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
See Also