KeynoteEntry Class

KeynoteEntry Class

Represents an entry in the keynote table, containing the key value, keynote text, and parent key (if applicable).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBKeyBasedTreeEntry
    Autodesk.Revit.DBKeynoteEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class KeynoteEntry : KeyBasedTreeEntry
Public Class KeynoteEntry
	Inherits KeyBasedTreeEntry
public ref class KeynoteEntry : public KeyBasedTreeEntry
type KeynoteEntry = 
    class
        inherit KeyBasedTreeEntry
    end

The KeynoteEntry type exposes the following members.

Constructors
 NameDescription
Public methodKeynoteEntry(String, String) Constructs a new KeynoteEntry from the given key name and keynote text. KeynoteEntry objects created from this constructor will not have parents.
Public methodKeynoteEntry(String, String, String) Constructs a new KeynoteEntry from the given key name, parent key name, and keynote text.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from KeyBasedTreeEntry)
Public propertyKey The key of this entry.
(Inherited from KeyBasedTreeEntry)
Public propertyKeynoteText The text associated with this KeynoteEntry.
Public propertyParentKey The parent key of this entry.
(Inherited from KeyBasedTreeEntry)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from KeyBasedTreeEntry)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetChildrenKeys Gets a collection containing the keys of all children entry objects from this entry.
(Inherited from KeyBasedTreeEntry)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also