Revit 2025.3 API
Curtain |
Add CurtainGrid on the specified face for the CurtainSystem.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void AddCurtainGrid( Reference face )
Public Sub AddCurtainGrid ( face As Reference )
public: void AddCurtainGrid( Reference^ face )
member AddCurtainGrid : face : Reference -> unit
Parameters
- face Reference
- The face new CurtainGrid will be created on.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument face is . |
InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails. |
See Also