Revit 2025.3 API
Filter |
A filter rule that operates on string values in a Revit project.

SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterStringRule
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterStringRule
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The FilterStringRule type exposes the following members.

Name | Description | |
---|---|---|
![]() | FilterStringRule | Constructs an instance of FilterStringRule. |

Name | Description | |
---|---|---|
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule) |
![]() | RuleString | The user-supplied string against which strings from a Revit document will be tested. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from FilterRule) |
![]() | ElementPasses |
Derived classes override this method to implement the test that determines
whether the given element passes this rule or not.
(Inherited from FilterRule) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetEvaluator | Gets the evaluator that implements the test for this rule. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetRuleParameter |
Returns the ElementId of the parameter associated to this FilterRule if there is one,
or invalidElementId if there is no associated parameter.
(Inherited from FilterRule) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | SetEvaluator | Sets the evaluator that implements the test for this rule. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

All string comparisons in this class are performed in the case-insensitive manner.
See Also