Revit 2025.3 API
Filter |
A filter rule that operates on string values in a Revit project.

SystemObject
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterStringRule
Autodesk.Revit.DBFilterRule
Autodesk.Revit.DBFilterValueRule
Autodesk.Revit.DBFilterStringRule
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The FilterStringRule type exposes the following members.

Name | Description | |
---|---|---|
![]() | FilterStringRule | Constructs an instance of FilterStringRule. |

Name | Description | |
---|---|---|
![]() | RuleString | The user-supplied string against which strings from a Revit document will be tested. |

Name | Description | |
---|---|---|
![]() | GetEvaluator | Gets the evaluator that implements the test for this rule. |
![]() | SetEvaluator | Sets the evaluator that implements the test for this rule. |

All string comparisons in this class are performed in the case-insensitive manner.
See Also