FilterRule.ElementPasses Method

FilterRuleElementPasses Method

Derived classes override this method to implement the test that determines whether the given element passes this rule or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool ElementPasses(
	Element element
)
Public Function ElementPasses ( 
	element As Element
) As Boolean
public:
bool ElementPasses(
	Element^ element
)
member ElementPasses : 
        element : Element -> bool 

Parameters

element  Element
The element to test against the rule.

Return Value

Boolean
True if the element satisfies the rule, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also