FilterRule Class

FilterRule Class

Defines a boolean operation that can be used to cull elements from a document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterRule
    More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FilterRule : IDisposable
Public Class FilterRule
	Implements IDisposable
public ref class FilterRule : IDisposable
type FilterRule = 
    class
        interface IDisposable
    end

The FilterRule type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FilterRule
Public methodElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also
Inheritance Hierarchy