FilterInverseRule Class

FilterInverseRule Class

A filter rule that inverts the boolean values returned by the rule it contains.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterRule
    Autodesk.Revit.DBFilterInverseRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FilterInverseRule : FilterRule
Public Class FilterInverseRule
	Inherits FilterRule
public ref class FilterInverseRule : public FilterRule
type FilterInverseRule = 
    class
        inherit FilterRule
    end

The FilterInverseRule type exposes the following members.

Constructors
 NameDescription
Public methodFilterInverseRule Constructs a new instance of FilterInverseRule.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FilterRule)
Public methodElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetInnerRule Gets the rule being inverted.
Public methodGetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetInnerRule Gets the rule being inverted.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
FilterInverse rule performs a logical "not" operation on its inner rule's "elementPasses()" method.
See Also