SharedParameterApplicableRule Class

SharedParameterApplicableRule Class

Tests whether an element supports a shared parameter.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterRule
    Autodesk.Revit.DBSharedParameterApplicableRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SharedParameterApplicableRule : FilterRule
Public Class SharedParameterApplicableRule
	Inherits FilterRule
public ref class SharedParameterApplicableRule : public FilterRule
type SharedParameterApplicableRule = 
    class
        inherit FilterRule
    end

The SharedParameterApplicableRule type exposes the following members.

Constructors
 NameDescription
Public methodSharedParameterApplicableRule Constructs an instance of SharedParameterApplicableRule.
Top
Properties
 NameDescription
Public propertyParameterName The name of the parameter that an element must support to pass this rule.
Top
Methods
 NameDescription
Top
See Also