SharedParameterApplicableRule Class

SharedParameterApplicableRule Class

Tests whether an element supports a shared parameter.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterRule
    Autodesk.Revit.DBSharedParameterApplicableRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SharedParameterApplicableRule : FilterRule
Public Class SharedParameterApplicableRule
	Inherits FilterRule
public ref class SharedParameterApplicableRule : public FilterRule
type SharedParameterApplicableRule = 
    class
        inherit FilterRule
    end

The SharedParameterApplicableRule type exposes the following members.

Constructors
 NameDescription
Public methodSharedParameterApplicableRule Constructs an instance of SharedParameterApplicableRule.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule)
Public propertyParameterName The name of the parameter that an element must support to pass this rule.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FilterRule)
Public methodElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also