FormArray Class

FormArray Class

An array that contains form objects.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBFormArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FormArray : APIObject, IEnumerable
Public Class FormArray
	Inherits APIObject
	Implements IEnumerable
public ref class FormArray : public APIObject, 
	IEnumerable
type FormArray = 
    class
        inherit APIObject
        interface IEnumerable
    end

The FormArray type exposes the following members.

Constructors
 NameDescription
Public methodFormArrayInitializes a new instance of the FormArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyItemGets or sets a form at a specified index within the array.
Public propertySizeReturns the number of forms that are in the array.
Top
Methods
 NameDescription
Public methodAppend 
Public methodClearRemoves every form from the array, rendering it empty.
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodInsert 
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Top
See Also