LinkConversionData Class

LinkConversionData Class

This class contains the information necessary to re-create a Revit document from an external source.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBLinkConversionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LinkConversionData : IDisposable
Public Class LinkConversionData
	Implements IDisposable
public ref class LinkConversionData : IDisposable
type LinkConversionData = 
    class
        interface IDisposable
    end

The LinkConversionData type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyPath The path to the source data used to generate the model.
Public propertyServerId The service responsible for converting the data into a Revit file.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the LinkConversionData
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetOptions Extra information used during the creation of the Revit document.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also