Revit 2025.3 API
Parameter |
Checks that the parameters of the rules used by the given ElementFilter are valid for this filter's categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool AllRuleParametersApplicable( ElementFilter elementFilter )
Public Function AllRuleParametersApplicable ( elementFilter As ElementFilter ) As Boolean
public: bool AllRuleParametersApplicable( ElementFilter^ elementFilter )
member AllRuleParametersApplicable : elementFilter : ElementFilter -> bool
Parameters
- elementFilter ElementFilter
- The ElementFilter containing the rules to check.
Return Value
BooleanTrue if all the parameters of the given rules are valid for this filter, otherwise false.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also