DirectShapeType.HasExternalGeometry Method

DirectShapeTypeHasExternalGeometry Method

Checks whether the externally tagged geometry is already present in this DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool HasExternalGeometry(
	ExternalGeometryId externalId
)
Public Function HasExternalGeometry ( 
	externalId As ExternalGeometryId
) As Boolean
public:
bool HasExternalGeometry(
	ExternalGeometryId^ externalId
)
member HasExternalGeometry : 
        externalId : ExternalGeometryId -> bool 

Parameters

externalId  ExternalGeometryId
The external ID of the externally tagged geometry to check.

Return Value

Boolean
True if such an externally tagged geometry is already present in this DirectShapeType, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also