AdaptiveComponentFamilyUtils.IsAdaptivePlacementPoint Method

AdaptiveComponentFamilyUtilsIsAdaptivePlacementPoint Method

Verifies if the Reference Point is an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsAdaptivePlacementPoint(
	Document doc,
	ElementId refPointId
)
Public Shared Function IsAdaptivePlacementPoint ( 
	doc As Document,
	refPointId As ElementId
) As Boolean
public:
static bool IsAdaptivePlacementPoint(
	Document^ doc, 
	ElementId^ refPointId
)
static member IsAdaptivePlacementPoint : 
        doc : Document * 
        refPointId : ElementId -> bool 

Parameters

doc  Document
The Document
refPointId  ElementId
The ReferencePoint id

Return Value

Boolean
True if the Point is an Adaptive Placement Point.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also