AdaptiveComponentFamilyUtils Class

AdaptiveComponentFamilyUtils Class

An interface for Adaptive Component Instances.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAdaptiveComponentFamilyUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class AdaptiveComponentFamilyUtils
Public NotInheritable Class AdaptiveComponentFamilyUtils
public ref class AdaptiveComponentFamilyUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AdaptiveComponentFamilyUtils = class end

The AdaptiveComponentFamilyUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberGetNumberOfAdaptivePoints Gets number of Adaptive Point Elements in Adaptive Component Family.
Public methodStatic memberGetNumberOfPlacementPoints Gets number of Placement Point Elements in Adaptive Component Family.
Public methodStatic memberGetNumberOfShapeHandlePoints Gets number of Shape Handle Point Elements in Adaptive Component Family.
Public methodStatic memberGetPlacementNumber Gets Placement number of an Adaptive Placement Point.
Public methodStatic memberGetPointConstraintType Gets constrain type of an Adaptive Shape Handle Point.
Public methodStatic memberGetPointOrientationType Gets orientation type of an Adaptive Placement Point.
Public methodStatic memberIsAdaptiveComponentFamily Verifies if the Family is an Adaptive Component Family.
Public methodStatic memberIsAdaptivePlacementPoint Verifies if the Reference Point is an Adaptive Placement Point.
Public methodStatic memberIsAdaptivePoint Verifies if the Reference Point is an Adaptive Point.
Public methodStatic memberIsAdaptiveShapeHandlePoint Verifies if the Reference Point is an Adaptive Shape Handle Point.
Public methodStatic memberMakeAdaptivePoint Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.
Public methodStatic memberSetPlacementNumber Sets Placement Number of an Adaptive Placement Point.
Public methodStatic memberSetPointConstraintType Sets constrain type of an Adaptive Shape Handle Point.
Public methodStatic memberSetPointOrientationType Sets orientation type of an Adaptive Placement Point.
Top
See Also