AdaptiveComponentFamilyUtils.IsAdaptivePoint Method

AdaptiveComponentFamilyUtilsIsAdaptivePoint Method

Verifies if the Reference Point is an Adaptive Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsAdaptivePoint(
	Document doc,
	ElementId refPointId
)
Public Shared Function IsAdaptivePoint ( 
	doc As Document,
	refPointId As ElementId
) As Boolean
public:
static bool IsAdaptivePoint(
	Document^ doc, 
	ElementId^ refPointId
)
static member IsAdaptivePoint : 
        doc : Document * 
        refPointId : ElementId -> bool 

Parameters

doc  Document
The Document
refPointId  ElementId
The ReferencePoint id

Return Value

Boolean
True if the Point is an Adaptive Point (Placement Point or Shape Handle Point).
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also