AdaptiveComponentFamilyUtils.GetNumberOfPlacementPoints Method

AdaptiveComponentFamilyUtilsGetNumberOfPlacementPoints Method

Gets number of Placement Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static int GetNumberOfPlacementPoints(
	Family family
)
Public Shared Function GetNumberOfPlacementPoints ( 
	family As Family
) As Integer
public:
static int GetNumberOfPlacementPoints(
	Family^ family
)
static member GetNumberOfPlacementPoints : 
        family : Family -> int 

Parameters

family  Family
The Family

Return Value

Int32
Number of Adaptive Placement Point Element References in Adaptive Component Family.
Exceptions
ExceptionCondition
ArgumentException The Family family is not an Adaptive Component Family.
ArgumentNullException A non-optional argument was null
InvalidOperationException This operation failed.
See Also