ParameterFilterRuleFactory.CreateEqualsRule(ElementId, String) Method

ParameterFilterRuleFactoryCreateEqualsRule(ElementId, String) Method

Creates a filter rule that determines whether strings from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static FilterRule CreateEqualsRule(
	ElementId parameter,
	string value
)
Public Shared Function CreateEqualsRule ( 
	parameter As ElementId,
	value As String
) As FilterRule
public:
static FilterRule^ CreateEqualsRule(
	ElementId^ parameter, 
	String^ value
)
static member CreateEqualsRule : 
        parameter : ElementId * 
        value : string -> FilterRule 

Parameters

parameter  ElementId
A string-typed parameter used to get values from the document for a given element.
value  String
The user-supplied string value against which values from the document will be compared.

Return Value

FilterRule
Created filter rule object.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also