FormattedText.GetPlainText(TextRange) Method

FormattedTextGetPlainText(TextRange) Method

Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public string GetPlainText(
	TextRange textRange
)
Public Function GetPlainText ( 
	textRange As TextRange
) As String
public:
String^ GetPlainText(
	TextRange^ textRange
)
member GetPlainText : 
        textRange : TextRange -> string 

Parameters

textRange  TextRange
The given TextRange.

Return Value

String
The substring of the text in a plain text form.
Exceptions
ExceptionCondition
ArgumentException This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException A non-optional argument was null
See Also