FormattedText Class

FormattedText Class

FormattedText is used to create, edit and format text in a TextNote or to query the text and format properties of a TextNode
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFormattedText

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FormattedText : IDisposable
Public Class FormattedText
	Implements IDisposable
public ref class FormattedText : IDisposable
type FormattedText = 
    class
        interface IDisposable
    end

The FormattedText type exposes the following members.

Constructors
 NameDescription
Public methodFormattedText Creates a new default FormattedText object, which contains only a carriage return character and has no formatting.
Public methodFormattedText(String) Creates a new FormattedText object with unformatted text.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodAsTextRange Returns a TextRange object that represents the entire text.
Public methodDisposeReleases all resources used by the FormattedText
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodFind Returns a text range identifying the first occurrence of the given string within the text, starting from a given index.
Public methodGetAllCapsStatus Returns whether All, None or a Mixed of characters in the entire text are in all caps.
Public methodGetAllCapsStatus(TextRange) Returns whether All, None or a Mixed set of characters in a given text range are in all caps.
Public methodGetBoldStatus Returns whether All, None or a Mixed of characters in the entire text are bold.
Public methodGetBoldStatus(TextRange) Returns whether All, None or a Mixed set of characters in a given text range are bold.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetIndentLevel Returns the indent level of the paragraphs in the text range.
Public methodGetItalicStatus Returns whether All, None or a Mixed of characters in the entire text are italic.
Public methodGetItalicStatus(TextRange) Returns whether All, None or a Mixed set of characters in a given text range are italic.
Public methodGetListStartNumber Returns the list start number of the paragraphs in a given text range.
Public methodGetListType Returns the ListType of a paragraph.
Public methodGetMaximumIndentLevel Returns the maximum allowed indent level
Public methodGetMaximumListStartNumber Returns the maximum allowed list start number.
Public methodGetMinimumListStartNumber Returns the minumum allowed list start number.
Public methodGetPlainText Returns the entire text in a plain text form.
Public methodGetPlainText(TextRange) Returns a substring of the text in a plain text form. The start and end of the substring is identified by a given TextRange.
Public methodGetSubscriptStatus Returns whether All, None or a Mixed of characters in the entire text are subscripted.
Public methodGetSubscriptStatus(TextRange) Returns whether All, None or a Mixed set of characters in a given text range are subscripted.
Public methodGetSuperscriptStatus Returns whether All, None or a Mixed of characters in the entire text are superscripted.
Public methodGetSuperscriptStatus(TextRange) Returns whether All, None or a Mixed set of characters in a given text range are superscripted.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetUnderlineStatus Returns whether All, None or a Mixed of characters in the entire text are underlined.
Public methodGetUnderlineStatus(TextRange) Returns whether All, None or a Mixed set of characters in a given text range are underlined.
Public methodSetAllCapsStatus(Boolean) Sets the characters in the entire text to be in all caps or not.
Public methodSetAllCapsStatus(TextRange, Boolean) Sets the characters in a given text range to be in all caps or not.
Public methodSetBoldStatus(Boolean) Sets the characters in the entire text to be bold or not bold.
Public methodSetBoldStatus(TextRange, Boolean) Sets the characters in a given text range to be bold or not bold.
Public methodSetIndentLevel Sets the number of tab stops that the paragraph should be indented.
Public methodSetItalicStatus(Boolean) Sets the characters in the entire text to be italic or not italic.
Public methodSetItalicStatus(TextRange, Boolean) Sets the characters in a given text range to be italic or not italic.
Public methodSetListStartNumber Sets the list start number on the paragraphs in a given text range.
Public methodSetListType Sets the ListType of a paragraph.
Public methodSetPlainText(String) Sets the entire text with the given text in a plain text form.
Public methodSetPlainText(TextRange, String) Sets the text with the given text in a plain text form in a range.
Public methodSetSubscriptStatus(Boolean) Sets the characters in the entire text to be subscript or not subscript.
Public methodSetSubscriptStatus(TextRange, Boolean) Sets the characters in a given text range to be subscript or not subscript.
Public methodSetSuperscriptStatus(Boolean) Sets the characters in the entire text to be superscript or not superscript.
Public methodSetSuperscriptStatus(TextRange, Boolean) Sets the characters in a given text range to be superscript or not superscript.
Public methodSetUnderlineStatus(Boolean) Sets the characters in the entire text to be underlined or not underlined.
Public methodSetUnderlineStatus(TextRange, Boolean) Sets the characters in a given text range to be underlined or not underlined.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

An instance of FormattedText can be obtained from a TextNote (See TextNote.GetFormattedText()) or from a TextNode (See TextNode.GetFormattedText())

It is also possible to create a new instance of FormattedText and assign it to a TextNote (See TextNote.SetFormattedText()) This will result in a TextNote with text with the specified formatting applied

Formatted text can be used to:

Formatted text can be populated with plain text by using its constructor FormattedText(String) that takes a string, or by using the SetPlainText(String) method.

In addition, selected ranges of text can be added, removed, or replaced with the SetPlainText(TextRange, String) method by specifying a TextRange.

Use the Find(String, Int32, Boolean, Boolean) method to find the location of existing text.

Formatted text can have up to 30,000 characters. All characters, except the linefeed character ('\n'), are allowed. This means that you should not use the 'Environment.NewLine' property, since that includes a linefeed character. Use the carriage return character ('\r') to terminate a paragraph. And use a vertical tab character ('\v') to create a new line without terminating the paragraph.

Formatted text allows for individual characters to be formatted. The following formatting can be applied.

  • Bold
  • Italic
  • Underline
  • Superscript/Subscript
  • All Caps
Use SetBoldStatus(TextRange, Boolean)) , SetItalicStatus(TextRange, Boolean)) , SetUnderlineStatus(TextRange, Boolean)) , SetSuperscriptStatus(TextRange, Boolean)) , SetSubscriptStatus(TextRange, Boolean)) , or SetAllCapsStatus(TextRange, Boolean)) to set the character formatting on a range of text.

Use GetBoldStatus(TextRange)) , GetItalicStatus(TextRange)) , GetUnderlineStatus(TextRange)) , GetSuperscriptStatus(TextRange)) , GetSubscriptStatus(TextRange)) , or GetAllCapsStatus(TextRange)) to get the character formatting of a range of text.

Text can be broken up in paragraphs. Paragraphs are terminated by a carriage return character ('\r').

Each paragraph can be indented several levels deep. For each additional level the indentation increments by one tab size. The total indentation is the product of a tab size and the indent level. Use SetIndentLevel(TextRange, Int32) to set the level of indenting up to a maximum indent level that can be obtained from GetMaximumIndentLevel Use GetIndentLevel(TextRange) to find the indent level of a given range of text.

Note that the tab size is determined by the object that will contain the FormattedText.

In the case of a TextNote the tab size is a property of the TextNoteType returned from TextNote.TextNoteType. The tab size can be found by calling the ParameterGuid with TEXT_TAB_SIZE on the TextNoteType obtained from the TextNote

In the case of a TextNode the tab size can be obtained from its TabSize property

Formatted text can also be used to create numbered or bulleted paragraphs with the SetListType(TextRange, ListType) method.

The following ListType options are available:

Paragraphs with a ListType other than None are considered to be 'list' paragraphs. Consecutive list paragraphs with the same indentation level are treated as part of the same list. A list ends when a list paragraph is followed by Note that a list will continue uninterrupted after list paragraphs that have higher indentation level. These paragraphs form a 'sub-list' of the list they interrupt. Sub-lists can have their own sub-sub-lists. The nesting level is only limited by the maximum indent level. Using SetIndentLevel(TextRange, Int32) it is therefore possible to create multi-level lists.

FormattedText will keep lists consistent. That means that list paragraphs will automatically get sequential numbers or letters. It also means that if the list type of one of the paragraphs in a list is changed then that change is propagated to all the paragraphs in that list. Note that this will not affect the list type of any nested sub-lists.

Use a vertical tab character ('\v') to insert a line without a bullet or number. Since this does not end the paragraph this will allow the list to continue to the next paragraph.

See Also