Revit 2025.3 API
Formatted |
Sets the text with the given text in a plain text form in a range.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetPlainText( TextRange textRange, string plainText )
Public Sub SetPlainText ( textRange As TextRange, plainText As String )
public: void SetPlainText( TextRange^ textRange, String^ plainText )
member SetPlainText : textRange : TextRange * plainText : string -> unit
Parameters
- textRange TextRange
- The given text range.
- plainText String
- The given text in a plain text form.

Exception | Condition |
---|---|
ArgumentException | This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. -or- plainText contains invalid characters such as a newline character. -or- plainText (excluding a carriage return character ('\r') at the end) has more than 30,000 characters. -or- Replacing the text in textRange with plainText will exceed 30,000 characters. |
ArgumentNullException | A non-optional argument was null |

Any individual formatting present in the range before will be lost after applying this function
and the text in the range will have uniform formatting.
The given text will be inserted if the given text range is empty.
The given text should have no more than 30,000 characters.
The the resulting text may not exceed 30,000 characters.
Newline characters ('\n') are not allowed.
See Also