RenderingQualitySettings Class

RenderingQualitySettings Class

Represents the quality settings of rendering.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderingQualitySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RenderingQualitySettings : IDisposable
Public Class RenderingQualitySettings
	Implements IDisposable
public ref class RenderingQualitySettings : IDisposable
type RenderingQualitySettings = 
    class
        interface IDisposable
    end

The RenderingQualitySettings type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLightAndMaterialAccuracyMode A value that controls light and material accuracy mode.
Public propertyRenderDuration A value that controls render duration.
Public propertyRenderingQuality The quality applied for rendering.
Public propertyRenderLevel The render target level as a numerical value between 1 and 40.
Public propertyRenderTime The render target time as a numerical value between 1 and 32768.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RenderingQualitySettings
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCustomQuality Checks if the current rendering quality is custom or not.
Public methodIsValidRenderLevel Validate the render level is between 1 and 40
Public methodIsValidRenderTime Validate the render time is between 1 and 32768.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The other properties in this class can only be modified if the RenderingQuality property is currently set to Custom.
See Also