StairsEditScope Class

StairsEditScope Class

StairsEditScope allows user to maintain a stairs-editing session.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBEditScope
    Autodesk.Revit.DBStairsEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class StairsEditScope : EditScope
Public Class StairsEditScope
	Inherits EditScope
public ref class StairsEditScope : public EditScope
type StairsEditScope = 
    class
        inherit EditScope
    end

The StairsEditScope type exposes the following members.

Constructors
 NameDescription
Public methodStairsEditScope Instantiates a StairsEditScope object.
Top
Properties
 NameDescription
Public propertyIsActive Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
(Inherited from EditScope)
Public propertyIsPermitted Tells if the edit scope is permitted to start.
(Inherited from EditScope)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from EditScope)
Top
Methods
 NameDescription
Public methodCancel Cancels the edit scope.
(Inherited from EditScope)
Public methodCommit Finishes the edit scope.
(Inherited from EditScope)
Public methodDispose
(Inherited from EditScope)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodStart(ElementId) Starts an stairs edit mode for an existing Stairs element
Public methodStart(ElementId, ElementId) Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Start/end of a StairsEditScope will start/end a transaction group. After a StairsEditScope is started, user can start transactions and edit the stairs. Individual transactions the user creates inside StairsEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into StairsEditScope constructor.
See Also